WASM: ERR_FATAL_FILE_ERROR (-239 / ffffff11)

Many of our users are hitting this error and are unable to use the wasm module in our aircraft:

WASM: Compiling module gauge.wasm
WASM: ERR_FATAL_FILE_ERROR (-239 / ffffff11)

We don’t know what this could be mean. I’ve had them check for free disk space and clear the cache folder that appears to contain the compiled wasm, but nothing helps.

Does anyone know what this is caused by, or have any ideas? The same wasm file works fine for many.

(removed 06-apr-2021)

I would be very grateful if any more person with expert knowledge could address this issue (WASM)! For me, this means that I can not use the H135 helicopter at all, which I am so looking forward to!

That’s fine pal… I removed my post :frowning:

I received a very kind message from fidelio1976 with a solution:

Hi, I often saw this problem for other users and mostly it is caused by a windows login name with special characters like “ü,ö,ä,ß,é” or something like that (in Germany this isn’t unusual). Then the folder C:\Users\günter for example is a problem and a lot of failures could happen, because saving files in %localappdata% fails. Also some 3D objects in SIM are not shown or other planes can not initialize. I saw the WASM failure three times because of this. It is necessary to create a new Windows profile without special characters and reinstall Flight Simulator 2020

We have not have full verification yet by someone who reinstalled and can now fly H135 but this sounds correct to me, exactly this issue has been seen in similar fashion before in other products.

Thanks for the reply! I also suspected the problem could be this. It is a bug that should be fixed by Asobo or Microsoft!
The problem is also discussed here:

I created a new account according to fidelio’s recommendation and it worked! That is, the problem with WASH was solved!

1 Like

Following this

Blockquote
There is a work around with what @BlondeAcrobat62 wrote or you can change Windows 10 to use the new Beta UTF-8 language set.

To do that, you have to go to “Control Panel” → “Clock and Region” → “Region” → “Administrative” Tab → “Change system regional configuration…” → and check the “Beta version: Use UTF-8 for language compatibility” checkbox.

Blockquote

Thank you for the information, I just checked this box in the Regional settings of W10 and now the beautiful Airbus H135 bird is working perfectly …
I myself have in my W10 account name an accent on my first name “Gérard”, and with this single checkbox, I avoided the heavy task of creating a new account and reinstalling MSFS, an often hazardous operation. …
It is unfortunate that it is the users who solve the problems which I believe should be solved by Microsoft or / and Asobo.
Thank you to everyone who shared their experience so that people in difficulty can get their heads out of the water and fly with the machine they love.

That solution seems to pose other problems, which I myself have experienced! see this post:

See special entries from January 25 onwards!

Yes thank you very much, I saw this post and I already used to delete the community folder before each game start.
I can choose a registered flight without worry.
I do have erratic flight plans, but others are correct.
For the moment I will uncheck the “Beta version: Use UTF-8 for language compatibility” box when I fly in H135, then I will un-check it again if this flight plan problem is really recurring, and I will definitely do this. deactivation if I decide to leave the H135 on the ground for a while …

Published on 04/10/2021:
Finally, I wanted to test if the H135 worked after having unchecked the box mentioned above and restarted W10.
Well yes the beautiful bird works perfectly, and the flight plans which were corrupted are correct.
Also I had some incomplete added little scenes which are ok now.
Looks like the “WASM” has done its job with this box checked and even unchecked it still works.
Hope this can help someone …