DA62X Improvement Mod (v0.9.1.1 Oct 22, SuX)

Sneaky! :sweat_smile: Is it 100% load or throttle? If I recall I was at around 85 to 90% throttle during climb.

above 96% load.

I think I broke this mod (and the WT CJ4) by using the “YourControls” addon. The throttle doesn’t work in the aircraft any more. I removed YC and deleted the DA62 from the sim and redownloaded but still not working. Can you offer any advice? Throttle works in the default DA62 without mod.
Thanks!

1 Like

Did you read the FAQ?

Anything else installed?

Yes I read the FAQs and saw the FADEC related issue.

Console shows that “DA62ECU.wasm” is being loaded. RPM sits constant at 710.

I removed all other mods and uninstalled YourControls.

is DA62ECU.wasm also being compiled?

I see these two lines:

WASM: Module DA62ECU.wasm initialized.
WASM: Module DA62ECU.wasm loaded…

I can’t see any other reference to that file.

2 Likes

Then there is the whole question of Turbo-Normalized and Turbo-Charged engines. :slight_smile:
Not all early turbocharged engines were quite as simple that you could firewall the throttles on the ground and leave them there until you leveled off.
They would theoretically destroy themselves by over-boosting in dense air. In that case the PIC would have to watch MP carefully to not exceed allowed parameters.

And of course Turbo-Compound R3350s with a 2-Speed Supercharger and PRT Turbines required even more finesse than just a power lever. The FE would actually shift the superchargers in flight from one gear to the other on #1 and #4 and then #2 and #3

1 Like

Imagine a twin with 8 levers.
throttle, RPM, mixture and wastegate
Throw carb heat in aswell

Well at least there would be enough to go around if you have to licensed pilots flying together :smiley:
My airplane partner and I always traded PIC responsibilities and SIC was in charge of all radio equipment and getting plates etc ready.
But at least I sometimes wished for something more to do. So I used the digital engine monitor to fine tune the IO-540 in flight :wink:

When dropping this into the community folder does it replace the stock asobo aircraft or will there be two twin diamonds? I have tried twice and it only appears to show the stock diamond.

Thanks.
Fzzt

MS store version of FS

Itll replace the default

1 Like

Look closely at the Image in the aircraft selection. If it has a dark grey triangle infront of the aircraft the Mod is loaded.

1 Like

I have same problem, throttle locked that does not respond to any input (joystick, mouse or keyboard) and engines in idle. The defect does it to me on this mod, that of the da40 and on Cj4 WT.
I have been testing for 3 days to understand the cause … The only thing I haven’t tried yet is reinstalling windows. However in my case it was not yourcontrol (which I do not know what it is :-D) and I have no idea why, because in the pc I have not added or removed programs and I have not touched anything in the sim.

if you find the cause, let me know. :slight_smile:

Thank you both! I see it now.

@MrTommymxr
I did some more testing since you replied 2d ago.
I downloaded your DA40 mod to see if that worked. It was fine the first time, then the throttle stopped working, just like your DA62 and the WTCJ4.
Sometimes, after deleting the mod folder and rebooting it would be ok but again, only for one time.
My community folder is not on the C drive. Could this be an issue?

No reverse thrust for DA62, correct?

Thank you for your work on the mod.

My community folder, my cache, and my initial install are on different drives.
It shouldn’t matter

i mean, its a simple change from a “0” to a “1” in the config file

Thanks for the great mod. I am looking for joystick bindings to turn the anti-ice, windsheild deice, and AUX fuel pumps on. Has anyone found any for these? I’ve had no luck with any.

1 Like