Darkstar Displays Not Working

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Cockpit displays of the Darkstar aircraft are blank after hitting “Ready To Fly” and loaded into the flight. First started happening after switching the flight model to Modern and reinstalling the Maverick DLC (this was to solve the uncontrollable flight characteristics issue). Now continues to happen after switching back to Legacy flight model and reinstalling the DLC again.

Provide Screenshot(s)/video(s) of the issue encountered:

Displays work before hitting “Ready To Fly”.


Displays go blank and dont work once fully loaded into the flight.

Detailed steps to reproduce the issue encountered:

As mentioned above, I switched the flight mode to modern, reinstalled the DLC and this issue started occurring. Happens every time loading into a flight (in both free flight mode and the Maverick Darkstar Challenge).

PC specs and/or peripheral set up if relevant:

Using Honeycomb Alpha and Bravo setup for yoke and throttle.

Build Version # when you first started experiencing this issue:

1.25.9.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Dont use legacy flight model.

It’s ONLY use is for a few user created aircraft that were originally from fsx and modded for msfs.

There are no default or market place aircraft that require legacy flight mode.

I don’t use it now after going through the control issues with Darkstar. I switched back to it just to see if it would have any effect on my issue which it doesn’t.

Any mods installed?
Empty community folder and test.
Also be sure any mods are newest and updated before putting them back.

I have the same problem

Do you have the pre-flight cinematic turned off? You have a inside view of the plane before pressing the ready to fly button. I think mine is an outside view, and I never have this problem, so try that.

Mine is on.

Is your community folder empty? And do you have any 3rd party content from the marketplace installed?

My answers are yes and no, respectively.

I had this same problem with blank control screens and wondered if this was something to do with the avionics master switch. Looked up the keyboard activation for toggling ‘avionics master’ which is ‘page up’ on the keyboard and momentarily turned on the screens but as soon as I released the page up button avionics screens turned off…
My solution: I have a spare toggle button on my VRinsight switch panel but I presume any keypad or button would do and I programmed that to turn the master avionics switch and it worked.
Note: I had the same problem with the new Halo Pelican and this also is working now.

Hope this helps anyone with the same dilemma!

1 Like

I started having this problem in all aircraft a few days ago and couldn’t figure out what was going on, as I’d never experienced it before. Based on your post, I tracked down the cause: my Honeycomb Bravo’s default bindings in-sim have one of the rocker switches set to ‘Avionics Master’, and with the switch in the up position, it was turning off the avionics. Flipped the switch and all works fine. I think sometimes after sim updates, controllers default to the default profiles, causing issues like this.

Well, after posting this I saw the same issue with the Caravan for the first time also, so I made a new profile for the Bravo and deleted everything, and then both aircraft displays worked. So it’s the Avionics Master switch that’s doing it eh, that makes sense and that button in the Pelican did look weird.

I don’t use the switch’s on my Bravo for much of anything as I have other panels for things like that, and this is the first time this has happened, plus I don’t use the default profile, but I also haven’t bothered to change the switch’s assignments on it either. Did they reverse the binding for the switch?

Thanks for your help getting to the bottom of this guys.

Well done Greg
I hadn’t made the connection between the Honeycomb Bravo and this current issue, I also have the Honeycomb Bravo but never dedicated a rocker switch to the Avionics Master. Will check this out tonight and remember to check this in future, I also noticed a similar issue with one or two of the generic aircraft with flat screens…you would you credit it!

Guys, anyone found a solution?
I deleted everything from my community folder and even done what [TermedCoyote18] suggested and set every control to default still no screens at all.