Discussion: World Update II: USA

How can I move in the cockpit now?

To solve this problem is important for me but also for the whole community because tomorrow can happen like me…halfway through the flight, I swear! halfway through the flight, every tree has disappeared and has never returned in all simulations.
try to reduce all the graphics and turn off everything even bing! in my opinion your images will be better than these! please try.

You need to remap the arrow keys in settings - controls. Increase/decrease pilot height and position.

1 Like

I can’t find how to remap though.

I’ll take a screenshot. Give me a moment to go into the Sim.


Go into Options, controls, select Keyboard, make sure Filter is set to all settings, scroll down to Cockpit Camera and set these:


managed to finally get the game installed after using Netlimiter 4 - took over 30 hours.

Only issue im having now is the game freezing for about 5 seconds every 5 mins or so.

I have left my MS install vanilla… updated the game via MS Store ( updated Store and XBox gaming services ) … 900 odd MB + 12 G for the update + 4+ Gig for content. All went well.

Fired up the Beech Baron at my home airport , live weather looked right, at medium settings, 100 LOD for terrain and objects, and High for Terrain textures ( Photogrammetry and rolling cache OFF ) , fps at 30 worked with no stutters.

Trees look better, objects were good. Didnt have to fiddle with my controls. In flight, used the Garmin to select an airport, and loaded an ifr procedure. Worked as expected, AP roll, pitch, hdg modes worked. Nav mode captured the new plan. Turned ap off to land by hand at a local airport, soft field approach, full flap landing… plane did not slow or balloon as expected , and brakes were almost non existent ( even w full application ) on rollout.

Crashed it… the title returned me to the main menu as expected without a ctd. More as i play with it some more, but this is an improvement.

No severe issues on first flight is a first.


You don’t have to remap your keyboard commands. The update included a new keyboard profile. All you have to do is change the profile back to default and all of your old key settings should be there.

1 Like

Can you please contribute to:

Night lighting issues still in update #7 - The community solutions - Self-Service / Bugs & Issues - Microsoft Flight Simulator Forums

This discussion has accumulated 489 votes and was not talked about in today’s Q&A, yet they’re asking for before/after material. This is a community driven discussion with lots of invaluable material and I believe your screenshots are helping.

1 Like

Hi, after this patch, it seems that cockpit tooltips and configuration windows (like when you select display resolution) are not getting proper configured screen resolution. I have a 3 monitors running at 1920x1080, so sim is set a full screen 5760x1080. Tooltips look huge! and same with popup windows.
Also my Carenado Pipper Simenole P44 crashes the sim whenever you chose to open the doors or move the sunshade.
Anyone have similar issues?

Anybody else noticing that some POI models are slow at loading? I flew to the Devils Tower and there was nothing there. Circled around the spot then the Tower just popped in place. Same issue with Crazy Horse. Nice models but had to be almost right on top of some before they show up.

I’m also interested on this, specially to see if the “limited by mainthread” is still tanking the FPS for people with RTX 2080ti / 30xx series with good CPUs like i9 9900K and the newer models. I know that you are supposed to be limited at some point because there is no hardware with infinite performance but I would like to see some improvements on that front, even if by 2 or 3 FPS on the minimums.


Thanks that works but I have to do this every time I want to visit marketplace!

One of your mods in the community folder is conflicting. You need to move them back one at a time or in small batches to find out which one(s). It’s because the mods are not updated for the new patch and cause a conflict of some sort

1 Like

What it means if you have an add on in your community folder that’s causing your grief. You need to ficure out which one it is.

Remove all your items, then start adding them back in a couple of them at a time. I like to do it in the order of importance they are to me. First, I do the G1000/3000 mods. I restart the game and see everythign works. Then I do the plane mods, restart and see if it works. Then scenery, then liveries. That way, you can narrow down what is causing you the issue.

I took a test flight test from Republic Airport on Long Island to Liberty Airport in New Jersey using the AI Pilot and IFR Low so that the way points were part of the flight plan. The plane took off and took a shortcut to the main part of the plan but then pretty much followed it although there was a lot of bobbing up and down at first. When it got into Liberty’s airspace the plane took a very wide path from the south, broke north past the airport and then back south on approach. OK, so far pretty much so good. The landing was very good except for one tiny detail. The AI Pilot landed on a taxi way instead of a runway. I could just picture the AI ATCs screaming over the radio :smile:

Technical detail, nothing to see here :grin:

There’s a small hill at the neighborhood park here in Springfield, IL at which folks like to watch the sunset. Prior to this update, you could see the winding sidewalk leading to the top, but the mesh was flat. There was no hill. Just loaded up the USA update to see, and there it was. Perfect. I set the date and time in the sim (bottom) to match the photo (top). If you look close, the moon phase and position matches too. Amazing.

Now I have a nice new landing challenge for the Shock Ultra :wink:


I noticed that with this update the CN Tower and Rogers Centre have been removed. The buildings around the downtown area have changed as well.

I know that there’s RomanDesigns Toronto add on for the GTA which does an outstanding job of depicting the GTA accurately.