Discussion: World Update II: USA

You can vote here for that:

1 Like

Well …

There is no graphical issue at that spot because there are no trees where you say there must be. When i check google maps … is GRASS

If you take off … and fly to the south … there should be maountains with huge forrests … did you check there ?


I noticed an FPS drop there on the discovery flight too - dropped from c. 45 to c. 20 for a few seconds - but recovered fine, no CTD. I wonder if there is a scenery glitch there

Do you have auto rudder on or have duplicate rudder controls set?

I had the same problem. Until I limited the download speed in my internet connection, then the problem went away. This is reproducible, if I do not limit the speed, the update for MSFS will always loop over and over on some of the files, especially the larger files.

This is where you go to limit speed if you have wifi (most routers use this exact default ISP, some are slightly different).

Yes that isp is the URL to type in your browser. A thread here had a whole lot of people saying limiting bandwidth cured the exact problem that you have. It cured my problem 100%. Now it never loops. Ever. But only when I check that limit box.

1 Like

Known issue. You can vote here to try to fix it:

1 Like

please if you can fly to the RCTP airport and compare my graphics with yours… I only have autogen. I really don’t understand!

1 Like

How can I move in the cockpit now?

To solve this problem is important for me but also for the whole community because tomorrow can happen like me…halfway through the flight, I swear! halfway through the flight, every tree has disappeared and has never returned in all simulations.
try to reduce all the graphics and turn off everything even bing! in my opinion your images will be better than these! please try.

You need to remap the arrow keys in settings - controls. Increase/decrease pilot height and position.

1 Like

I can’t find how to remap though.

I’ll take a screenshot. Give me a moment to go into the Sim.


Go into Options, controls, select Keyboard, make sure Filter is set to all settings, scroll down to Cockpit Camera and set these:


managed to finally get the game installed after using Netlimiter 4 - took over 30 hours.

Only issue im having now is the game freezing for about 5 seconds every 5 mins or so.

I have left my MS install vanilla… updated the game via MS Store ( updated Store and XBox gaming services ) … 900 odd MB + 12 G for the update + 4+ Gig for content. All went well.

Fired up the Beech Baron at my home airport , live weather looked right, at medium settings, 100 LOD for terrain and objects, and High for Terrain textures ( Photogrammetry and rolling cache OFF ) , fps at 30 worked with no stutters.

Trees look better, objects were good. Didnt have to fiddle with my controls. In flight, used the Garmin to select an airport, and loaded an ifr procedure. Worked as expected, AP roll, pitch, hdg modes worked. Nav mode captured the new plan. Turned ap off to land by hand at a local airport, soft field approach, full flap landing… plane did not slow or balloon as expected , and brakes were almost non existent ( even w full application ) on rollout.

Crashed it… the title returned me to the main menu as expected without a ctd. More as i play with it some more, but this is an improvement.

No severe issues on first flight is a first.


You don’t have to remap your keyboard commands. The update included a new keyboard profile. All you have to do is change the profile back to default and all of your old key settings should be there.

1 Like

Can you please contribute to:

Night lighting issues still in update #7 - The community solutions - Self-Service / Bugs & Issues - Microsoft Flight Simulator Forums

This discussion has accumulated 489 votes and was not talked about in today’s Q&A, yet they’re asking for before/after material. This is a community driven discussion with lots of invaluable material and I believe your screenshots are helping.

1 Like

Hi, after this patch, it seems that cockpit tooltips and configuration windows (like when you select display resolution) are not getting proper configured screen resolution. I have a 3 monitors running at 1920x1080, so sim is set a full screen 5760x1080. Tooltips look huge! and same with popup windows.
Also my Carenado Pipper Simenole P44 crashes the sim whenever you chose to open the doors or move the sunshade.
Anyone have similar issues?

Anybody else noticing that some POI models are slow at loading? I flew to the Devils Tower and there was nothing there. Circled around the spot then the Tower just popped in place. Same issue with Crazy Horse. Nice models but had to be almost right on top of some before they show up.

I’m also interested on this, specially to see if the “limited by mainthread” is still tanking the FPS for people with RTX 2080ti / 30xx series with good CPUs like i9 9900K and the newer models. I know that you are supposed to be limited at some point because there is no hardware with infinite performance but I would like to see some improvements on that front, even if by 2 or 3 FPS on the minimums.