Display Device Duplicate issue in VR

Brief description of the issue:

When I go into VR mode, HP Reverb G2, the headset displays correctly…But:

My primary display ( main screen ) remains active at the same time but switches to a stereo scopic view.

Correct me if I’m wrong but it seems my video card is simultaneously powering 3 displays: The left eye and right eye displays of the reverb G2 and my primary display.

How do I configure the settings to use just one display Device at a time? Either my VR headset OR primary display device?

Seems to me I could free up a lot of video memory if my nVidia 2080TI did not have to drive three 4k screens at the same time.

Thanks in Advance.


try changing the display mode to windowed from full screen and then minimise the main simulator window when in VR mode, your pc should then be only rendering the display in your VR headset. so, to recap…go to options- general- graphics- display mode- windowed- then minimise when you enter VR mode. hope this helps.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.