DNS Server Not Responding After MS2020 Update?

It seems after the MS2020 (5) update my DNS server becomes non-responsive . This only happens after I have been flying for 15 to 20 mins. or more. Only when using MS2020 internet connection, does this happen. This is strange. At no other time when using my computer does this take place.
The only way to resume connection to the internet is by restart. Anyone else experiencing this anomaly ??

If you Alt-Tab out of the sim and leave it running, then launch an Internet browser and can get to outside web sites (i.e., pick a news site for example so you know you’re not looking at cached data), then your DNS settings were not touched.

In general, the sim would not manipulate your current network connection. It’s relying on a working connection to function even if you’re not using Live Services like Weather or ATC. It needs a working connection to authenticate you into the sim via XBox for Windows account (the Gamertag you use in this board).

Sounds logical, however it only happens when I use MS2020.
Why is also that others are recently reporting internet irregularities . I use X-plane and P3D with no issue. As I mentioned this is a recent occurrence , with in the the last week or so. Might it be connected to the multiplayer live connect bug that many are experiencing ? Any recommendations?

I’m on Steam, and I regularly run with Live Weather, Live AI Traffic ON and Multiplayer OFF. Offline ATC Text to Speech since I have a custom Locpak file. Bing Maps and PG ON. No issues with any of the streaming services I have. I also run with a single web browser window, Discord and Little Nav Map (which has an NOAA wind feed).

To your point, try shutting or turning Offline or to Preset all the online services and see if it persists. And then enable them one by one to see if you can isolate a culprit service.

What DNS provider are you using? If you haven’t manually set one it will be a generic one, possibly set by your ISP.

Ok maybe I’m not 100% clear on what’s going on. {Let me restate} First I just did a 5hr flight KLAX to PHLI on X-plane , no internet issues at all. After I begin a flight on MS2020 with in 15 to 20 min. I can not log onto the internet . My Internet access bar bottom right shows connected, yet any page I try to access will not pull up. I then have to shut down MS2020 and restart the system or wait another 15 or 20min for my internet to resume. I ran the trouble shooter several times error says " computer configured correctly no access to DNS server" I am stumped. {Again this is after the SU5 update}

Hello @Starseed55 ,

how fast is your internet connection?
Maybe all the bandwidth is used up by MSFS?

The Google DNS servers are a popular alternate to ISP DNS servers.

Sorry for the delay in responding, I see @PacificSet90456 beat me to my point…

While it probably isn’t your issue here, I would still switch to a reputable DNS server. Consider one of these providers:

Provider Primary Fallback
Cloudflare -
1 Like

So my up speed is( 6.5 mbps) and down speed is (120.2 mbps) which I presume is more than sufficient.
How do I go about switching to a google DNS? I have never had to do this before. Why would that be an issue? I have a brand new top of the line gaming system. Might this be related to the multiy-player connection problem after the SU5?

Thank you all for your input and recommendations.

It probably isn’t your issue, but it’s still a good idea to use a more reliable DNS provider anyway. When I do a fresh install of Windows, one of the first things I do is switch my DNS provider. Here is a guide: Get Started  |  Public DNS  |  Google Developers.

Out of curioisty, when you have this issue, can you still access websites if you know the IP address?

As you can see my usage is low and performance is high across the board even with live weather ,logged on to vatsim and vatspy running in the background.
Never tried to longing on using just an IP / where do you acquire an IP for say flightsim.to ?

Your bandwidth is high enough, that it shouldn’t be a throughput issue. It sounds like an issue with your computer DNS cache, and/or the DNS servers you are using, hence the suggestion to change to Google or Cloudflare :slight_smile:

Next time you are having issues try going to and see if that works.

As an FYI: Computers don’t reach servers using domain names, they use IP addresses. The Domain Name System (DNS) is how computers can look up a domain name to find out the IP address they need to go to.

If you can still access a website using an IP address (i.e. without translating a domain to an IP address), then that proves your internet is still working.

Thank you, I will report effects after making the amendments

I am seeing occasional spikes ,Is that a problem?

And now THIS??

FYI, if your ISP is xfinity/comcast - they are doing system wide update.

Nope, everything ok.

Ok good to know I do have Xfinity , However why would that effect my internet connection only when using MS2020? Just happen again after about 20min. of flying my internet will either drop out or take a long time to connect to a webpage. Usually timeout. The sim stays connected and v-pilot and it seems live weather as well.

Nyx1819 : by the way the internet does connect with the IP address you sent rather quickly when the issue occurs.