Do I need a link cable with the Oculus Quest 2?

Small OT: I’m thinking to refund the Rift S and getting a Quest 2, especially for the higher resolution, since the characters on the flight displays are not really readable. Do you think does it worth doing the exchange?

I’m getting there. When I do that it tells me that the app doesn’t have permissio. I can’t find MSFS anywhere in Oculus to change permission. I installed XBox but it’s not showing up.

Can you specify the exact message you get and from which program it comes (MSFS, Oculus)?

I’m there finally. I had to go into the Oculus software and allow apps from Unknown Sources. Thanks for all the help. What is the empty black frame that’s floating around?

1 Like

if you get the weird black frames, disable the ‘Use FOV Stencil’ with the Oculus debug tool.

image

You can use the Oculus Debug tool like @MortThe2nd said, or update the Oculus PC software to the latest beta version. You do this by going into the settings, select the Beta tab en then set Public Test Channel to enabled.

See also this link at the top section:

Is the Link Cable required for us with slow poo internet mine is only 2.4ghz around 100-120mpbs

Hi, I am using the usb-c to usb-c charging cable that came with the headset. I Can’t switch from the flat virtual screen to VR. I have everything configured as stated by Microsoft, just when I press control+tab or through the options menu I never switch to full VR. Can it be that I need a usb-a to usb-c cable that I must buy separately? Can you confirm please?

My answer is No, No, No!

Using Virtual Desktop to stream SteamVR over WiFi to Oculus Quest 2 will give you a much better performance. Actually it’s even much better than with Oculus Rift S. I tested Rift S, Quest 2 with Link cable, and finally Quest 2 over WiFi. The third was way way better.

Please see my below post:

Virtual desktop is not a viable option for everyone: my pc has a wi fi connection and Virtual Desktop was actually unusable. By the way i got a Quest 2 and i did a simple test: trying reading the small glass cockpit characters and was actually better than the Rift S! Also the resolution was downsample respect to the native render resolution but still higher than the Rift S, so there is still room for improvement!

Wiring PC to router with Ethernet cable will improve WiFi streaming experience. Of course the router must support 5G well, I am using Netgear Orbi, a good one but certainly not top notch.

Sorry but for me and my 6700k/3080 setup, Link gets me 10 fps more and with better quality…I’ve gone back and forth way too many times comparing the two. And VD runs great for me in general with other games so it’s not a network thing for me.

1 Like

Hi, How did you get quest 2 to work full VR? I have tried everything, and still can’t get to pass the flat virtual screen. I can’t get the screen to split in two and have full VR. Any suggestions? Thanks

Unfortunately wiring the PC to the ethernet is not possible, since the router is in an another room.

Stupid question: did you tried to enable the VR mode from MSFS? This seems an issue not directly related to the Quest 2… Take a look here [Read First] VR Known Issues & Workarounds

Sure thing, tried many times and it does recognize the headset, but it just won’t change to full VR.

Make sure you have enabled “allow unknown sources” in the Oculus software.

3080 is of a totally different league than my 1660 Super, and I believe while my goal was only stable 20-35 FPS your goal is probably higher. So Oculus Link solution may very well be a better solution for you and people with better hardware.

Take off your headset and check your PC screen. If it even failed to enter VR mode from PC screen, likely you will see a “no headset found” message. If so, you might not have loaded SteamVR successfully through Virtual Desktop.

One way to make sure SteamVR works is to play another game there with Virtual Desktop WiFi connection before you try MSFS.

Another thing you can try is to use “Enter VR Mode” from within MSFS instead of using Ctrl-Tab, or vice versa. With Virtual Desktop + Steam VR + MSFS, occasionally the mouse on screen would stop working even if you can still move pointers and highlight things in MSFS.

Yes, I entered VR mode from within MSFS. However after that you may have to use the left controller menu key to bring up the Virtual Desktop menu and select “Play in VR”(exact name may be different). Otherwise you might only see a split screen on virtual PC from headset, or (rarely) a window with 3D MSFS VR view but moved with your head.