Do I need a link cable with the Oculus Quest 2?

Virtual desktop is not a viable option for everyone: my pc has a wi fi connection and Virtual Desktop was actually unusable. By the way i got a Quest 2 and i did a simple test: trying reading the small glass cockpit characters and was actually better than the Rift S! Also the resolution was downsample respect to the native render resolution but still higher than the Rift S, so there is still room for improvement!

Wiring PC to router with Ethernet cable will improve WiFi streaming experience. Of course the router must support 5G well, I am using Netgear Orbi, a good one but certainly not top notch.

Sorry but for me and my 6700k/3080 setup, Link gets me 10 fps more and with better quality…I’ve gone back and forth way too many times comparing the two. And VD runs great for me in general with other games so it’s not a network thing for me.

1 Like

Hi, How did you get quest 2 to work full VR? I have tried everything, and still can’t get to pass the flat virtual screen. I can’t get the screen to split in two and have full VR. Any suggestions? Thanks

Unfortunately wiring the PC to the ethernet is not possible, since the router is in an another room.

Stupid question: did you tried to enable the VR mode from MSFS? This seems an issue not directly related to the Quest 2… Take a look here [Read First] VR Known Issues & Workarounds

Sure thing, tried many times and it does recognize the headset, but it just won’t change to full VR.

Make sure you have enabled “allow unknown sources” in the Oculus software.

3080 is of a totally different league than my 1660 Super, and I believe while my goal was only stable 20-35 FPS your goal is probably higher. So Oculus Link solution may very well be a better solution for you and people with better hardware.

Take off your headset and check your PC screen. If it even failed to enter VR mode from PC screen, likely you will see a “no headset found” message. If so, you might not have loaded SteamVR successfully through Virtual Desktop.

One way to make sure SteamVR works is to play another game there with Virtual Desktop WiFi connection before you try MSFS.

Another thing you can try is to use “Enter VR Mode” from within MSFS instead of using Ctrl-Tab, or vice versa. With Virtual Desktop + Steam VR + MSFS, occasionally the mouse on screen would stop working even if you can still move pointers and highlight things in MSFS.

Yes, I entered VR mode from within MSFS. However after that you may have to use the left controller menu key to bring up the Virtual Desktop menu and select “Play in VR”(exact name may be different). Otherwise you might only see a split screen on virtual PC from headset, or (rarely) a window with 3D MSFS VR view but moved with your head.

You probably have to use your left controller menu key to bring up Virtual Desktop settings menu, and click on “enter VR” button. Pressing left controller menu key longer or shorter may bring you different things, sometimes it’s VR view itself. This is because SteamVR also uses left controller menu key to switch between menu and VR. Now with Virtual Desktop using the same key to bring settings menu, you actually have another way to force SteamVR to bring you into MSFS VR.

I do have it, thanks

I tried that, and still no full vr. All other games are fine. Just no split screen (full vr) in msfs. Thanks!

Weird. So far in my case, as long as SteamVR “tiny window” was there and MSFS didn’t give error message, enter VR mode (either from PC or from virtual screen) would at least bring a split on PC screen.

Have you manually modified registry to use SteamVR *.json file for MSFS runtime?

So, i did again a trial with Steam VR to check how smooth it is…
My config Ryzen 5 2600X, RTX 3070, 32 GB RAM, 1 TB nvme M2, Quest 2

I didi many tests between the two modes, Link and Steam VR.

Last situation was Link with Nvidia 457.30, Oculus Openxr runtime, all set to Ultra is MSFS, some settings modified trhough OculusDebug Tool.
Result is very smooth, cpu and Gpu load around 50/60%. Quite pleasant to fly.

So i did again a test on Steam VR, same parameters, no changes with Oculusdebugtool, runtime openxr of Steam, same setting in MSFS.

Result was not as smooth as Link, a bit shaky, but flyiable. But Cpu was at 50% and GPU was at 100%.

So, seems better with Link, but i don’t think that i found a really satisfactory solution.

To me the difference was huge: with Link cable and Oculus OpenXR, my “headroom” (as displayed in Tray Tool overlay) was at best -200 but would easily deteriorate to very unstable -500 to lower than -1000.

I agree that there must be other factors and issues that made my Link cable worked so badly in MSFS. It’s a good thing we can have two VR solutions here that may suit different people with different expectations.

BTW, I have a slow CPU which often becomes the bottleneck in MSFS. Lesser CPU usage may mean big difference in my case.

Yes, I modify the registry, And still no full vr. Just the flat virtual curved panel.

But did you notice that the MSFS image within that curved panel was 3D like in VR? You turned head it just followed? And SteamVR control panel remained in front?

If so, left controller menu key should work. If not, you might get light blue empty VR just as what I got last night. This meant MSFS VR worked but SteamVR failed to put you inside. I had to restart the whole sequence to fix that.

If your panel was just flat like in desktop, without even split screen, then MSFS failed to start VR mode.

Yes I tried that. And it’s failing to get me in VR. Maybe an update from ms will fix it? I am crazy now, have tried every suggestion to no avail. Don’t understand why I hoy split screen twice the day of launch and since then nothing