Does the elevator trim even work any more?

The trim seems to have stopped working. It used to be num.7 and 1 for down and up trim, but now that seems to have no effect whatsoever. I have tried to assign buttons to this function, using both keyboard and joystick, but to no avail.
Incidentally I cant get the brakes to work either.

I mostly fly the Savage Cub, but the Daher has lost its trimming abilities also. The Daher is even worse, it unpredictably overtrims itself into an unsalvageable climb or a fatal dive. The cub sometimes does that as well, but it is usually better behaved.
I am new to this ( had it a week) so its entirely likely it is me and not a bug, but please help all the same!
Thanks and happy new year!!

Did you check to see if you were in “Legacy” or “Modern” flight model under General Settings.
You should be in modern.

Maybe check that trim isn’t assigned to an axis on another device.

Thanks for the suggestion. I Tried that just now. It makes no difference. :thinking:

Yup. Done all that, it still doesnt work. I deleted all the other things that were assigned to Num1 and num7, but when I hit those numbers nothing changes. I tried a plug in keyboard also.

I have the same issue. Elevators refuse to budge on all of my aircraft using either the yoke or trim buttons on yoke handles. Sensitivity setting is modern; cannot see any cross assignment on controls. This predicament occurred with the 22 December update and has made MSFS unusable.


The only workaround I can find is quite funny. You have to set it as straight as you can, get into cockpit view and lower your “eyeline” to the trimming wheel. Using the mouse, and the hand grab, you adjust that, and get back into chase view to see if you have hit the number you want!

You might also check if some kind of assistance has been actived, AP or AI copilot engaged.

Drop your graphic settings back. That is how I got mine to work again.

1 Like

I will try that. It makes some sense. Just as I got the graphics singing!

1 Like

Flying on HARD. You are right, switching away from autopilot makes it lose control completely. Specially that Daher

1 Like

Have another look into this, mate, if you haven’t fixed it yet. I found I had the same problem after the update. What turned out to be going on was that the cockpit displays were showing the elevator trim wasn’t budging, and when I tried on the pilot-side trimmer, that showed to not be budging according to the pop-up box that comes up when you hover over it (not sure it that is set by default or if you have to set the pop-up info in the settings).

When I tried on the CO-PILOT side, however, I saw that the elevator trim was set to like 20 degrees nose down, and when I adjusted THAT, I saw from the pop-up info that it was moving. I brought it back to 0 degrees, neutral. Oddly, the cockpit readout (I was using the 747) showed 7.5 the whole time, and never went to any number lower than 7.5, but once I had adjusted the co-pilot trimmer, it WOULD show numbers ABOVE that (8.2, 15.7, whatever), but the trimmer worked as normal from that point on, and it would show the little arrow moving up & down the scale. I could adjust it on my flight stick, the pilot side trimmer, where ever.

I also have FSUIPC7, the latest version, installed, and I have the MSFS Voice Attack app found on the MSFS Nexus Mods page, and I can’t rule out that either of those 2 apps have had anything to do with my being able to get the trimmer working. So if you still have no luck, try installing those 2 things.

Good luck.

1 Like

Appreciate the guidance.

Oddly, I removed the CH Yoke and then re-connected its usb cable to my computer and voila, the control work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.