Double download of all Packages content - what now?

When I initially downloaded the game a year and a half ago, I put the install on my C drive and my Packages (Community and Official) in the exact same folder structure on my D drive.

So the game itself was on C, all the Community and Official content was on D.

I was in the Beta for the most recent sim update. When I left the Beta (which you have to at the end), I restarted the sim, and it wanted to download like 130GB of content. I guess it’s a known issue that sometimes this happens, and it’s legit, and you have to do it. (Do you see where this is going?).

The sim redownloaded EVERYTHING onto my C drive that I already had on my D drive. It has been running this way for the past two weeks. When I was trying to solve another problem, I realized what had happened. The UserCfg file was looking at:


But I was expecting it to be looking at:


SO. Now I have two copies of the sim Packages on my computer. Now what do I do? I have updated UserCfg to point to my Packages on my D drive. So now the next question is, because everything in the Packages files on my C drive is just a duplicate, I can delete it all, right? Now that the sim is pointing correctly to the Packages folder on my D drive?


Move the full community folder to where you want it after deleting the empty one and place the most recent Official one next to it choosing to replace if prompted. If you still have the spare Official folder on the other drive just delete it. Update the path in UserCfg. In sim check for updates.

MS Store

My FS2020 is installed on my D: drive but looks like this:

My UserCfg.opt points to: InstalledPackagesPath “D:\FS2020”.

Be careful:
Note that FS2020 (1.xx GB )must be installed on the C: (or boot) drive.
The “Installed Packages” (130 GB) can be on another drive.
If you delete it from the C: drive, it will not run anymore.

This depends. For the steam version this is not true: the sim is installed in the sim library wherever it is located. In my case it is not C: . I have only some config content under c:users/username/appdata/…
All other stuff is located on another harddrive.

Seems like a good procedure to me, then I’ll have the most recent of all the files. Doing it now, will let you know how it goes. Thanks all for your replies.

1 Like

It’s giving me permission issues, but I think it’s because the Official folder on my C drive is read-only. So I’m changing that for the files in there now.

Just one more point. Your new Community and Official must be in a folder e.g. D:\MSFS and not directly in the root of the drive e.g. D:\ Community

1 Like

Is there a particular reason for that? Just curious.

My “new” Community folder (aka my “old” Community folder on my D drive, where I want everything) is in a string of subfolders, not in a root folder. I just recreated the folder structure on my D drive that the game had originally created on my C drive:


(This isn’t a “true” Users\AppData folder like the one on my C drive, it’s just what I named the folders to match the C… I think I did it so I could find everything if I needed to. In any event, it has worked just fine)

I don’t know why it must be that way but its not limited to MSFS. Another tip, don’t reacreate the original file system as some mods struggle with the long path name even in the default location. Mine is simply D:\MSFS2020 and it works wonderfully.

1 Like

Awesome suggestion. I can’t remember why I did that in the beginning, but I did.

I had a similar situation without knowing, (I run this on one machine with 2 diff os install win 10 and 11)
when I realized what was going on I simply went to the the directory(s) I didnt want and deleted them.

Next time the sim fired up, it asked where I wanted it (120 gigs again), I told it where the install I didnt delete was, and bang it ran straight away and quit asking.

When I booted into the other install win 11 same thing launched it from steam, the game started running asked me where I wanted the install at, I pointed it to the dir I had it installed in and bang, ran straight away, and never asked again.

My problem was that under 10 the install drive is d: but under 11 its f: but all is better now…

1 Like

Ah that makes sense! I will keep that as an option in case what I’m doing right now doesn’t work. Basically right now I just redirected the userCfg file back to my D drive and it’s running fine, I’m just trying to decide what to do with the “fresh” downloads on my C drive.

Dont worry if you break it it will grow back LOL a little KOH humor there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.