Download and Installation of v

I’ve noticed that I’m not the only person who has encountered a similar problem but I can’t seem to understand that any of the solutions proposed do not work in my case.
I downloaded the simulator from the Microsoft store last Friday “01/15/21”. After downloading it I went to the installation stage on the app. The first few hours were alright however things took a turn to the worst when I reached “fs-package-001”. The installation froze and after a few seconds, the window closes on its own.
I tried every this proposed on this forum concerning the problem, however, nothing seems to work.

Hello Knox 4181,
I have had the same problem. I downloaded Flight Simulator Premium Deluxe after completely uninstalling the app. and after waiting 2 days for the app to be downloaded from Microspoft Store, I seem to experience the same. The only thing that is different from your post is I am at fs-base-0.1.87.fspatch.002. I have been trying to get a complete install, and I guess I will wait like you, for additional assistance from the Forum. Hang in there my friend, and you’ll succeed with patience. As a real world pilot, I use FS20 to practice IFR approaches. This deffinitely saves time and money. I also use the digital approach plates and can practice a approach when I am away from the house. I have an Alienware gaming laptop, so if there is a hotspot, I can connect. Portability is my No.1 purpose.

1 Like

SoliderBasil887, I really appreciate your reply to my concern my friend. Good luck to you too

Sure thing.

Have you looked in the FAQ?:
Error message “Package failed” when trying to download and install packages – Microsoft Flight Simulator Support (

Download stuck on packages / Install loop – Microsoft Flight Simulator Support (

If you have set any data limits (bandwidth speed or data cap) in the MSFS Options settings, this may also cause the download to stop or go slow.

If you are getting decompression errors - you can manually extract the files using WinRAR or 7-Zip

If you have truly tried everything listed in the FAQ and forum search (such as using netlimiter or a VPN), the please file a zendesk report about this.

I’ve been searching the FAQs and thanks for the additional sites. I will let you know if something works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.