DX12, VRAM usage. A work in progress: Sharing my settings

The way I have reduced VRAM usage when running dx12 is lowering texture resolution. One hardly notices any texture degradation with below settings and VRAM usage sits between 94% to 105% depending on airport. (105% @ EGLL)
You can monitor your current usage via OpenXR toolkit: F2 - Performance Tab - Overlay - Choose advanced.

For reference, here are my system specs and settings:

(Some OpenXR screenshots taken with previous version. Works fine with latest version)

I fly exclusively in VR

Avarage FPS: 45
Hp Reverb G2
Cpu: Amd 5800x3d
Gpu: AMD 6900 xt



Changed to use latest preview OpenXR Tools for Mixed Reality runtime.
Set prefer frame rate over latency in Open XR tools
Disabled Turbo mode (Experimental) in OpenXR Toolkit (this because of enabling Prefer frame rate setting over latency in OpenXR Tools)

To do:
Test the latest OpenXR Toolkit (1.3.2)
Retest VRAM usage due to discrepancy between toolkit vs adrenaline as per Mayhem6633’s post

Thanks for the idea and the settings. I have a ReverbG2/6900xt/5800x and I run DX12 using FSR quality.

Question: why do you care about VRAM usage? My texture resolution is high and I don’t have any problems. Frankly it just works so why do you worry? My VRAM usage shows over 100% in the toolikt but checking the adrenaline settings performance metrics it only shows 15.1 GB of the 16GB total so I think the toolkit is just wrong.

Question: what does your advanced field of view settings do in the OXR Toolkit? I notice you lowered the left/right and right/left settings. Why?

By the way, I think your CPU should be 5800x3D instead of 3800x3D. Also I think with the newest OpenXR Toolkit you want your OpenXR Tools to be using the latest preview in order to take advantage of the newest features in the toolkit.

1 Like

I noticed that, too.

Also I think the latest version of OXRTK is 1.3.1 on GitHub.

There was also a recent new release of Windows Open XR Tools for WMR application. Check the Microsoft store to see if you have the latest.

FYI: I checked today and 1.3.2 is available.

:laughing: Even I can’t keep up!

Reply is also for Mayhem6633’s post

Thanks for catching the typo: will change 3800x3D to 5800x3D

Concerning VRAM:
I had performance problems and constant stuttering. Troubleshooting led me to VRAM being too high in DX12. This was no problem with Dx11. The only setting that impacted VRAM usage for me was reducing texture resolution. This also allowed me to up most of the other settings compared to DX11.

What I’ll test after your suggestion: I see what you mean about VRAM usage in the toolkit vs adrenalin. I cross checked with GPU-Z. I’ll up texture resolution again and report back.

Concerning Advanced Field of view settings: Quote from Features | OpenXR Toolkit (mbucchia.github.io)
Field of view : Adjust the pixel density per degree. A smaller field of view is covering a smaller region of the view but with the same amount of pixels, effectively increasing the perceived resolution

This just sharpened the image a bit by increasing the perceived resolution. This makes it possible to read the mb numbers on the altimeter.

Downloading new toolkit and retesting settings, will amend first post with findings.


Me too with the latest SU update but didn’t trace it back to VRAM. I’m normally 45-50 fps but was running in the low 30s with stutters. The first thing I did was disable all my addons and that brought my fps right back to normal. I’m re-enabling them slowly and still haven’t found the culprit. I suspect it’s one of my scenery improvements like Bijan Seasons, GAIST, or the bunch of mamudesign addons I have.

That’s sweet. I’ll play with that for sure.

Here’s a tip for you since you were nice enough to share your settings.

As mentioned I’m normally at 45-50 fps when flying. I like to keep it that high so I can do the following. I notice that my GPU hotspot temp is low 90’s and it’s maxed out at 100% utilization. I run my fans at 95% in adrenaline to keep the temps from going higher. It’s pretty loud at that fan speed.

Here’s the tip: I like to cap my framerate at 38 fps in the OXR Toolkit on the first tab (frame throttling?). I find that capping at 38 doesn’t impact my smoothness at all. The advantage is on the GPU. At 38 fps my 6900xt only needs to run at like 80% utilization and the max frequency MHz drops from around 2500 to 1900. Thus when capping the GPU runs much cooler because it doesn’t have to work so hard and this allows me to lower the fans. So now I have the max fans at 75% which is significantly quieter and the hotspot temp is low 80’s.

So bottom line is you need your settings to normally be well above 38 so that you can cap at 38 and enjoy that benefit. I don’t like going lower than 38 because then I start to notice it. Anyway, good luck with the texture setting.

How the hell do you manage to have no rubberband with all the settings at ultra, except Texture Resolution?
I have a 5800x3d with a 6800xt and have to put almost all settings at Low in order to not a have rubberband when flying with my pico4

How do you get the AMD FSR 2 option in the Anti-Aliasing Menu? I also have a Full AMD system (7950x, 7900XTX) but it doesn’t show…

Are you set to DX12?

1 Like

Ahh, no, didn’t realise it needs to run in DX12. Will try it out later. Thanks


After your questions and suggestions I started from scratch. (Details below)

The Goal:

Get flightsim to run at it’s optimum in VR


  • Work with the hardware that I have.
  • One set of settings that’s applicable to both GA and Jetliner flying.

My system:

  • CPU: AMD 5800X3D
  • GPU: AMD RX 6900 XT
  • System memory 32GB
  • Hp Reverb G2


  • OS: Win 11 Version 10.0.22621 Build 22621
  • GPU driver: Adrenalin Edition 23.4.1
  • MSFS: v1.31.22.0
  • OpenXR Tools for Windows Mixed Reality: Runtime version 113.2304.14003
  • OpenXR Toolkit Companion app: v 1.3.2
  • Community folder:


Adrenalin Settings:

OpenXR Tools for Windows Mixed Reality Settings:


MSFS Graphics Settings:

MSFS Traffic Settings:

MSFS Data Settings:

OpenXR Toolkit Companion app Settings:

PMDG DC6 at EHRD with FStraffic (Screenshot taken in VR)

It’s all about balance. Our pc’s have a set amount of computing power. We obviously try to get the most out of our systems and in doing so we often err by asking too much.

If one compares the first set of settings I posted at the beginning of this thread to the settings in this post, one sees that they are vastly different from one another. The performance I got was more or less the same though. The second set of settings do give better visuals with better visual clarity.

Performance is good. At EHRD my CPU rdr timings are acceptable. Just after takeoff at rw06 the CPU rdr timing decrease to around 7.0. It’s a fairly build up area and EHAM is just a few km off the nose. FPS is good. Flying the DC6 averages about 45 FPS, but more important, it is smooth.

VRAM saturation seems high, but as Mayhem6633 has mentioned the toolkit seems to show usage too high when compared to Adrenalin and GPU-Z. (Thank you Mayhem6633 for pointing that out!)

Regarding resolution in VR. In researching settings, I’ve come across multiple suggestions of increasing the resolution in order to get better clarity. Every time I’ve tried those suggestions, I’ve killed my performance. Yes one should offset the performance drop by using FSR/DLSS, but using FSR below balanced diminished the clarity again. I run at 100% resolution (3168 x3100) and have good clarity and performance.

Thank you to everyone who has replied to this thread and given suggestions. It helps getting flightsim to run at it’s optimum in VR!

Keep your questions and suggestions coming.



I think it’s because of 2 things;

  • I keep my VR resolution at 100% resulting in (3168 x3100)

  • By lowering Texture resolution.

Note: As per post above. I’ve changed settings to be more in balance based on input on this thread

BigCow74 is correct. DX12 has to be set

Good suggestion. The GPU fans do get quite loud and lower temps are always good.

The cards junction temp (Hot Spot) is said to be fine going that high and the card will only start thermal throttling at 110C.

It would be interesting to see if things improved when you take out Bijan Seasons. I’ve always suspected Bijan’s to give a light stutter at airports. (I’ve never tested this conclusively though) Since I’ve moved on to REX Accuseason, I have hardly had any stutters. Have to say, looking to the side has always been less smooth than looking forward in every FS iteration.

Thanks a lot. Will try later with VD in Godlike mode (3120x3120), currently I’m using TAA with about 2300x2300. That’s the resolution I can keep that pesky rubberband off the objects and have a smooth ride even with broken clouds and also I can see the instruments way clearer than FSR(with about 2996x2996 resolution).

For people to see if they have rubberband I suggest doing a test at about 700ft and 300kts. Look out side and see if the objects are sharp without any rubberband dancing around the edges of the objects.

Let us know how it goes!

Your new settings are really close to mine now. I tried your first settings and agree these are visually better. I have a couple more comments.

In adrenaline, I do as you’re showing. I turn all the AMD stuff off except tesselation… like you. However regarding your voltage, my suggestion is to reduce it some. I did some testing of this and notice that if I lower the voltage then the GPU will reach a higher max frequency and it runs a little less hot. I agree that the GPU can go to 110C without issue so the temps are not a big concern but it does give a performance improvement as well. I currently have mine set to 1140. Going much lower does cause stability issues so don’t go too low.

Buildings, Trees, and Grass/Bushes impact my fps more than other settings. I have these on Medium. I get a few more fps and don’t notice a visual impact. Regarding the TLOD, I can run at higher values without a drop in fps. I’m at 175 now.

Have you ever noticed a white outline around water. When this is on I see a white outline where the water and land meet or where trees overhang water. So I turn this off and the white outline around water goes away.

FYI: I put Bijan Seasons back yesterday and didn’t have a performance drop. I’m still looking for which addon causes my fps drop but it’s not that.

Good luck.

Did your settings and to make it smooth with no rubberband had to put FSR at Balanced.
Using Pico4, VD, 72hz, Godlike mode(3120x3120). Smooth even with broken clouds.