Elgato Stream Deck + vs Loupedeck Live

I’m going to buy one of these devices and looking for advice on which device to pick based on your experience with one or both of these devices. I most often fly the C172 or Airbus 320.

You should read the reviews on YouTube of the Loupdeck live before deciding on your purchase. I use the Elgato and love the way it works…

Do you have the problem of it seeming to go into sleep mode that’s hard to wake it up from?
I have sleep mode OFF in the settings, but the screen still goes black. Sometimes I can wake it up with a lower panel wipe, and sometimes I have to open the Stream Deck software to get it to Page 1. I’ve read that it’s an ongoing issue. I thought I had it fixed by setting it to sleep after 2 hours and assigning a screensaver. Seemed to work well - for a while. Now it’s back to going to sleep and becoming unresponsive.

Elgato recommends connecting it directly to an onboard USB port. But I’m out of ports on the back on the computer, and connect it instead to a powered USB hub. Maybe that’s the problem. I have USB selective suspend turned off in my power setting profile.

I used two 15 button stream decks and one stream deck + in my cockpit, worked great. Only reason I chose the SD+ over a Loupedeck was because I already had the other stream decks integrated in and figured I’d just keep it all relative. Plus there were already some great profiles created on flightsim.to for the aircraft I was flying, already with prebuilt scripts for axis and oh’s and everything.

From the WWW

How do I stop my USB from sleeping Windows 10?

Click Hardware and Sound, then click Power Options. Click Change plan settings for the plan you want to change. Click Change advanced power settings. Click the plus sign (+) next to “USB settings” and “USB selective suspend setting” to expand the options and change the setting to Disabled.

From my first post in this thread:

:wink: :wink: :wink:

Then check each of your USB devices to make sure of its power settings. Sounds like, from your description, that your USB device is being turned off by the computer to “save power”. fWIW

OK, thanks. I will do that.