Engine shutting down on IFR landing

This has happened to me a couple of times and I’m just not sure what it is.

One time it was in Norway approaching Bergen with a Cessna Skyhawk I believe. Second time just yesterday around the Aleutian Islands with a JMB VL3.

Engine just shut off by itself on final approach on both occasions, flying low at around 2000ft. I still had fuel left. The areas are cold but there were no icy conditions that I was aware of. Certainly there was no ice build up on the plane. Propeller kept working, but you could hear the distinct sound of the engine dying and the plane lost lift. All I could do is glide somewhere and hope for the best. The second time I was actually able to perform a water landing, surprisingly. I didn’t even know those were possible (I’m not playing under true to life settings but collisions are possible and normally the landing should’ve resulted in a crash).

I mention the final approach because the one thing both cases have in common is that I was approaching the airport following ATC directions and the problem happened right as I started the final maneuver.

In any case, I don’t know if this is a bug or something I’m not quite getting. Both times I had no idea what happened and I could not restart the engine.

I’ve had the same thing happen a few times as well. Once in the TBM and once in the freeware F-22. Plenty of fuel.

Some kind of transient bug.

Guess it’s a wrong key binding or similar. Never happened to me.
I would check all bindings, controller and keyboard.

It happened again, with a Beechcraft. North Africa over land, no IFR this time.

I didn’t touch any buttons, so it can’t be bindings. Engine just shuts down when you are in the proximity of the airport at a low altitude.

It’s rather annoying, having hour long flights ending in a crash because of this.

Have you tried

  1. looking at these settings to see they are not accidentally dis/enabled-
    Options - Assistance - Aircraft Systems - Unlimited Fuel
    Options - Assistance - Aircraft Systems - Failure & Damage - Engine Stress Damage
    Options - Assistance - Aircraft Systems - Failure & Damage - Icing Effects

  2. Auto starting the engines again (keyboard CTRL-E)

  3. Tried passing control to the AI pilot (not the auto pilot) to see if they can find a way of turning everything back on again even if just for a minute or two.

  4. Checking your mixture hasn’t been changed even accidentally

  5. Research on here shows that there was a bug relating to mixture on prop planes in 2020. Don’t know if was ever fixed. It may be worth researching further -

I’ve not seen this happen before, but I don’t spend a lot of time in the smaller prop planes other than the BN-2.

1 Like

Strange thing, it really never happened to me anytime and i started with the sim from the very first day.

Yes probably some double / wrong key binding… check any bindings for e.g. mixture, then any fuel related ones , I had that about a year ago in the TBM, although it does not have mixture as a turbo, the binding with mixture for flying the C172, shut off the engine mid flight when I accidentally touched the axis.

  1. Fuel was not unlimited but I had more than enough left. Engine stress damage was disabled, and so were the icing effects.

  2. Tried auto starting on both occasions, but didn’t work.

  3. I did not try passing control to the AI.

  4. Mixture was set to auto.

  5. I read about the mixture bug, but I’ve been assuming this wasn’t that because I had that set to automatic.

I’ve been flying with prop planes a bunch of time since I last posted and the problem didn’t return. But then again, it wasn’t something that happened every time. If it does reoccur, I’ll try switching to AI piloting since that’s the one thing I didn’t try.

1 Like

Ok, this just happened again. However, this time it happened at a high enough altitude that I could try quite a few things and I did fix the problem. I was flying IFR again, but I’m not sure that has anything to do with it anymore.

I was using the Cub Crafters X Cub.

  • I had around 24% fuel left. Low, but not empty.
  • The engine was definitely responding and trying to start, but couldn’t.
  • I did pass control to the AI this time, and they couldn’t restart the engine either.
  • Mixture was set to auto and working fine.

Right before hitting the ground, I moved the fuel up all the way to 100% and tried again. That finally made the engine restart. Sadly this was so close to the ground that there wasn’t enough time to save myself from the crash. But the engine did restart and had I done it earlier, it would’ve been fine.

So, the question is, why did I lose the engine at 24%? How low is too low with these planes? Because I’m pretty sure I have flied with far less than that before and it was ok.