Entering VR Mode Causes Blinking Between FS2020 and Oculus App Screens

Do you have any add-ons in your Community folder? No If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it? No

Brief description of the issue: During January 2021 VR with my Oculus Rift S worked. After updating Windows 10 Home Edition from 2004 through several updates to 20H2 19042.928, updating FS2020 to the current version in April 2021, and Oculus from V25 to V28.; activating VR mode and clicking the “Ready to fly” button causes the display (in both 2D and VR) to continuously switch between the initial VR display of the current FS2020 screen and the Oculus application’s Home Screen. This occurs at a rate of about 1.5 seconds between changing the displayed screen. Control mappings for VR have been adjusted to one mapping, a joystick button, to control the toggling of enter/exit VR mode. Exiting VR mode returns the 2D display to a normal FS2020 display.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered: I regularly applied normal updates to Windows 10, Nvidia drivers, Oculus drivers, and FS2020 between February 1st and April 15th. Family health issues prevented my using FS2020 until April 18th. Additional updates have been applied since the 18th, but they did not solve the problem.

PC specs for those who want to assist (if not entered in your profile) AMD Ryzen 12 core CPU, Nvidia RTX2060 (driver 466.11), DirectX 12.0, 32 MB RAM, Oculus Beta Program Member.

Build Version # when you first started experiencing this issue: How do I find the FS2020 build version?

Are you on the Steam or Microsoft Store version? Store version

Did you submit this to Zendesk? Not yet If so, what is your ticket #?

I had a similar problem and this worked for me.

Start your flight and turn off all ‘pop out’ screens (such as ATC, weather, checklists, etc.) before switching to VR.


I have EXACTLY the same issue on 2 different PC’s and with an Oculus Rift S headset and with a Medion Mixed Reality headset (all 4 combinations). Hence I am sure this must be a MS Windows of FS bug. I’ve spent days updating and testing.
Current configuration :

  • MSFS Store version
  • Both PC’s have Nvidia Graphics card with latest drivers (tested with older as well)
  • MS Windows has been updated to the latest version
  • Oculus version (latest)
  • No in-flight menu’s
  • Zendesk tickets #100403 (closed without solving !) and #103168

It is comforting to learn that I am not unique with my challenge. I submitted a Zendesk case last week. I will post their response here.

FYI, my Zendesk ticket is #104013. I made a MP4 file of what is displayed on the computer’s 2D display, but it is currently to big. I will try to drop the resolution to see if it can be made small enough to upload here.

By accident I started the MSFS in Windowed mode and now I can switch to VR mode (using Ctrl + Tab) !
For it solves the issue on both PC’s where MSFS2020 has been installed. Could you try if this solves it for you as well please ?

All fixed. Here is the deal:
I have 2 4k monitors, both on Display port. Run by an old Nvidea GTX 1070 (no i). I installed FS on 3 different machines, 2 with virgin installs of win 10 (latest build). One of the machines has a GeForce GTX 980 Ti.
2 machines are I7, one an I5. All machines are up to spec per Microsoft.
To me, 2 monitors is normal. [1 is 3840 x 2160 @ 30 Hz. The other is 3840 x 2160 @ 60 Hz) (Along with 2 laptops and a Linux webserver.)
Most people having only 1 monitor would not see this problem. I have no answer as to why it didn’t work when I disconnected 1 monitor (each monitor in turn, I tried both ways)
All modes were tested and have no bearing here. 1080, 1440 or 4k (3840) make no difference.
The Oculus beta test channel has no bearing. Tests good with or without. Developer mode does not matter.
Graphics mode either full screen or windowed, does not matter. The Oculus Diagnostic tool was not used and is in out-of-the-box configuration…
I could go on and on about what settings I have, but the problem turned out to be the FS pop ups. ATC, Objectives. VFR Map, even camera spec.
All must be shut down before entering VR mode. The flashing back and forth is Oculus trying to deal with the 2nd monitor open windows that are being controlled by MFS.
Open the windows after entering VR mode and all should be fine.

The down side: My Oculus Rift S resolution is half of my main screen (4k). I think it is 1920 (x2). But still cool as hell!

I am an old command line junkie from the 80s and know the old DOS and Linux (Ubuntu) well. Just so you know my background and why I was digging too deep instead of using common sense. Nothing showed up in any error logs that I could find. The Oculus log dump program put out a Zip file about 40 MBs. Did not know where to start looking.

This worked for me too! Thank you!

still had the same issues

here’s what I had to do in addition:
install steam vr
make steam vr the openxr app
enroll the the steamvr beta
unchecked the steamoverlays, etc., anything that would evoke steamvr i unchecked.
regedit the khronos\1 registry key back to the oculus_openxr_64.json
closed all apps
opened oculus
device green
opened msfs 2020 from desktop shortcut
got into the cockpit

no screens, no atc, no nothing selected, however THE ICON SHOWED that one / some where selected (but none were, the main icon was white). I selected all the options in the ones that said there was something, then went back and de-selected all.

checked the toolbar again, all icons not white
enabled VR mode
reset my position – expected the loop
and all of a sudden i’m sitting in the cockpit. after a few seconds, the vr map , atc and objects popped up in the vr. I was able to fly again (without STEAMVR, the framerate was horrible and choppy) smooth as expected.
before exiting, I made sure to close out all menu items in the vr. then disable the mode.
made sure all was closed out in cockpit before ending / exiting to desktop.

I now check the menus before enabling VR – until it’s fixed.

I have the same issue but ithappens only TO SAVED FLIGHTS !!!