Erratic joystick behavior

Well, yes, it is a cheap joystick (Hama), but it works just fine in FSX, and other games.
But in MSFS 2020, it is crazy! Impossible to control the aircraft. Releasing the stick does not level controls, moving a bit more to the left or right or pitch down or up is a disaster…
Throttle has two values - engine cut and TOGA…
Whatever I try to do in Sensibility has no effect. Crazy!
Joystick is calibrated just fine, gives correct inputs in Windows calibration.

Any idea, or it is just a bug and MS expect us to pay more for a piece of hardware than for the BEST SIM EVER?

the same here, normal trhustmaster joystick (cheap) but that works perfectly in xplane 11 and DCS, in this simulator literally the contours of the plane go crazy, honestly I don’t know what to do anymore, I have tried absolutely everything

If you are ever in doubt about whether an issue exists with the hardware (joystick etc) or in-game it can be useful to use DIView to check.

It’s an old and simple piece of standalone software that will ID and show the status of most axes and buttons. (There is a limit to number of axes and buttons but few mainstream peripherals will actually exceed this)

Can be downloaded here.

1 Like

Thanks for answering, I have everything well calibrated, in fact as I mentioned before in xplane 11 and dcs my ch quadrant and my joystick work perfectly without problem, but in this simulator the joystick is … I don’t know how to explain it … I am attaching one capture, all this with the joystick in neutral and everything well configured

There are a lot of reports that SU7 has automatically turned all assistance to “easy mode” therefore you may indeed be fighting automated systems that want to fly the plane for you.
Check the assistance settings.

I have everything totally realistic, I tried all the modes, realistic and easy and it still does not work, the pitch is mixed with the roll, only in the joystick, and I already tell you, I have tried everything and I don’t know what is happening if I’m honest, I don’t have the faintest idea

Have you tried creating a completely new profile?
Like literally unbinding everything so you have blank profiles for each peripheral and then slowly adding things back, starting with the primary control axes?
It would not surprise me that SU7 or some associated glitch might also really mess up input profiles. (They are stored in the cloud after all and I’m thinking they also included some input control tinkering in this update anyway)

I have tried everything, in fact it already happened the last time before the update there was no way the joystick control would work, it does a mix of pitch and roll together

EDIT: now I just discovered what it was and by chance … by default the simulator assigns the joystick axes Y and X to the mouse, that is, there were 4 axes, that’s why the joystick went crazy and the planes went crazy, anyway I will monitoring this, and if it happens again I will let you know