FBW A320 Altitude Hold not holding

Anybody have any altitude hold issues in the FBW 320 after the WU6? Does not seem to want to hold selected altitude. Worked great before the update.

Which version?

PC MSFS 2020 and latest version of FBW A320.

Stable, Development or Experimental?

If you’re on Development or Experimental it would be a surprise for me, because it’s working well on my end.

I had a problem yesterday whereby it didn’t follow the flight path and I got it back on track by flying direct to next waypoint
it missed a waypoint on the Star as well so had to manually intervene , this all happened over s 2 hour flight so once FBW upgrade the development mod then I’m sure all issues will be fixed

It’s the stable version. Maybe try the developmental version?

I also may try getting rid of 3rd party add ones from community folder. This only happened after WU6.

Update: I deleted the liveries out of the community folder and that fixed it. Thanks to all who replied. Great help as always…
Just to be clear, this was never a problem with the FBW A320. Those guys do a fantastic job giving us a quality aircraft sim!

Glad it worked, sometimes leftover files from updates/corrupted installations may cause these types of issues. A reinstall should ideally fix it. Also, it’d be recommended to download/update liveries directly from flightsim.to since there are occasional model updates that require the liveries to be updated as well, making some liveries in the livery packs obsolete

Yeah, the development version has the custom autopilot - or even experimental for improved LNAV.


I have FBW A32NX 0.6.3 (last stable).
I can reach desired altitude 30000ft with AP on with correct heading.
But, once I reach desired altitude, AP turned off itself.
I have tried to turn on again, but, instead holding the altitude, my plane dive with crazy vertical speed.
I have tried to turn off and on auto thrust too, but it didn’t help.

The only way to save plane from diving itself is let AP off and climb manually to desired altitude (manual until landing). If I try to turn on AP again, it will dive again.

Is this bug or I made mistake flying with this plane?

I usually fly with Icon A5, C152, and C172. Lol

I would guess you are doing sth wrong or your joystick is interfering with the AP.

But without a screenshot or a video it is a bit of guesswork what exactly it is.

I will try screenshot next time.
Unfortunately, I can’t recording properly while flying.
Last time I tried record using GFExperience giving me CTD after SU5, Xbox Game Bar giving me choppy/stutter frame rate video.

1 Like