FBW A320 can't change heading mode to managed

New info. The cursor doesn’t change like in all the videos I have viewed on the subject. I’m supposed to be getting an arrow and I get a hand.

Had a similar problem as the OP but with the Altitude, wouldn’t go into Managed Mode but was happy enough with manual selection. But about to begin my descent it started to work again with no obvious reason. Maybe an instability in the latest Dev version (which was quite a big download this time) - will check it out next flight.
FBW say you must use Modern flight profile. Personally can’t get a handle on Locked mode - perhaps these old fingers of mine aren’t as dexterious as they used to be!!!

In Lock mode you left-click and HOLD, then either right-click or middle-click WHILE HOLDING the left button. It just takes a little practice to get the hang of it. Try it out for a week.

New info. Yesterday I was almost able to complete a whole flight. The suggestion to right click while holding down the left worked. It worked again today for the ascent but when I started the descent it stopped working. My altitude knob was showing yellow when I clicked on it. I’m beginning to think it has something to do with my A/C configuration as I was attempting a descent from FL350 to FL300 through the ATC script to request a cruise level decrease. The FP didn’t have me descending for another 80 miles. I was attempting to give myself a little leeway from the auto generated ATC. It seems to me they wait too long. Not really looking for a solution at this time, Just documenting my experience.