FBW A32NX taxiing issues

Hello all,

I have the Saitek rudder pedals and the a32nx installed, I’m having issues when taxiing, the aircraft tend to want to pull right and struggles to keep on a straight line. Is anybody else experiencing similar issues? I’ve tried updating the drivers, unplugging the device, without any success. I appreciate the help. Thank you.

Have you tested this on other aircraft? It could be either your hardware issue or binding issue.

…and you don’t have any strong winds on the airport?

I checked the calibration of the device and it shows going the full range on each way of the axis. I’ll test it more closely with other aircraft as well. I just wanted to be sure it wasn’t a known bug for the aircraft but rather on my end only. I’ll investigate further and report back thank u.

So I tried to unplug the device and plug it in another port. The results were the same…the calibration of the rudder axis shows to be spot on in the simulator I can move the rudder left and right on the aircraft…however, when I apply power to start taxiing the aircraft immediately starts to turn towards the right and I have keep corrscting left to keep it straight. This happens with other aircraft’s as well. Any suggestions?

  1. Check the deadzones in your controler sensivitiy settings. Move them up if needed.
  2. Check if your key/button mapping is maybe configured wrong (double mapping of a key)
  3. Do you have footbrakes? Check their sensitivity settings and mapping too.
  4. Do you have twin throttle levers? Are the engines spooling up asynchronous?
  5. Do you have any other controlers connected (steering wheel, xbox controler, etc)? Unplug them and try again.
  6. Do you have any other mod installed? Remove them (temporarily) and try again.

I followed your bullet points to a T and it helped on keeping the aircraft straight while taxiing. This is the scenario I’m faced with… I load the aircraft on the gate get it all setup pushback, start engines, taxi, the aircraft behaves well… take off, land…that’s when the issue creeps back… as soon as I come to complete start and get clearance to resume taxi that’s when the aircraft starts pulling right again. no matter how little I throttle the aircraft it just wants to pull right. the rudder is at 0 the calibration in msfs 2020 shows to be right in the middle…I tried X-Plane and no issues there…could this be a bug?

I don’t think this is a bug, since you seem to be the only one having this. Are you using any external third party tool (e.g. FSUIPC)?

No sir only the a32nx mod. The next thing I’ll check if the liveries are creating this issue. I have read that some liveries for the a32nx sometimes interfere with the mod. Thank u do much for the reply and the help.

Yes, custom liveries can also interfere with the mod.

If his didn’t help: to really find out what the problem is, I would sugggest the following:

  1. Unplug your joystick/controler and check if the issue still occurs (when steering with keyboard only).
  2. Reset ALL keybinds/mappings, axis settings to default (in MSFS) and try again. Also your joystick settings.
  3. if this also didn’t help: reset ALL MSFS settings (also assistant settings) to default and see if that helped.

Thank you for the suggestions I’ll give all of this a try and let u know the outcome.

Have a wonderful day.

1 Like

Update…I removed the entire mega pack liveries and the aircraft now works fine… I will download the single livery from flightsim.to. I wanted to thank you for all ur help. Best wishes…

2 Likes

Update:
So I thought my trouble were over… I’m still having issues with the aircraft. I’ve narrowed the issue to the following:

  • I load MSFS 2020 NeoA32nx on the gate, push back and start, no problem, start to taxi, no problem, take off no problem… at landing I touchdown and when I finally come to a stop then restart taxiing I notice the aircraft immediately can’t keep a straight line but tends to go right. I have to use a good amount of left rudder to stay straight. I tried quick take off and landing with the b787 and haven’t noticed the same issue. I don’t think it’s related to the length of the flight. I have tried everything…I uninstalled the aircraft and reinstalled it from the installer, I have removed every livery, I have plugged in my rudder pedals (saitek rudder pro) into every usb port and the problem still persist…unfortunately there’s no way of calibrating the rudder pedals manually, however, when i log in to MSFS it shows to be right in the middle. any suggestion is appreciated thank you.

what about rudder trim? There’s a button to reset the rudder trim to neutral.

Could the Auto Pilot still be activated and trying to steer the plane? Just stabbing in the dark.

Tried all those suggestions autopilot off and trim 0.

Could it be your rudder controls acting up? or if there’s a wind or something?

I suspect the hardware being the culprit. Over the weekend I will make an experiment and use the rudder from the t1600 stick and deactivate the rudder pedals that way ill know if the issue is related to hardware or software. Thank u for the good ideas and helping me out in this process. I’ll keep u guys posted.

Hello all,
major update… so i finally got to the bottom of the issue… in short i was using pushback helper and i was hitting the page up button on the keyboard to make it appear and disappear, not realizing that page up was bound to increase steering command… well i have now removed the keyboard command and voila problem solved. wow i’m so grateful to have resolved the issue. I’d like to thank all of you for the help.

2 Likes

Yeah, I removed all my keyboard bindings to an empty profile.