Feedback on Copilot / AI Control Aircraft

Hi, I wanted to describe my experience with the Copilot / AI Control Aircraft for future improvements. I copied this from another thread and put it here so the proper people can also see it. Thanks!

Some observations regarding Copilot / AI Control:

Setup: Los Angeles to Amsterdam, IFR high-altitude, starting with 787 parked at gate. Just turn on Control Aircraft and see what it does. (I used the new livery). I noticed that the CG was out of range above 84% fuel - before this update, the CG was within limits up to 93% fuel. I didn’t bother trying to adjust the weight distribution for this experiment, but thought that this was an interesting change.

Fixed: The VFR Map / flight plan route glitch is no longer there, where certain legs of the flight path go back and forth to the same waypoint. Now the flight path is correct.

Otherwise, from startup to taxi, everything was the same. What worked well still worked well, and vice versa. It still doesn’t turn on lights or set altimeter, so I did that manually.

Takeoff: As usual, it did not set the flaps until takeoff roll. However… rotation! It rotated at takeoff speed instead of crashing at the end of the runway! Hooray!

After takeoff: For the first few seconds, I was worried as the aircraft initially started making a left turn away from the flight path. I thought it was going to fly off in some random direction again. But after a few seconds… it turned back to the right and followed the flight path! HURRAY! However, I did notice that once on the flight path, it would over-correct during course corrections, causing the plane to make shallow right and left turns instead of flying straight. But at least it was following the flight path, so that’s a huge improvement! I also noticed that after reaching cruising altitude, the throttle remained at 100% instead of reducing thrust for cruising speed. (More on these issues next.)

Cruising altitude: After reaching cruising altitude, as described above, the throttle remained at 100% achieving a speed of over mach 0.9 instead of cruising speed. The aircraft continued to make shallow right and left turns instead of flying in a straight line. I experimented by turning off the AI Control Aircraft feature and turning on the actual autopilot instruments instead. The result was that the aircraft stopped making the shallow right and left turns, and instead flew straight and level, following the flight path as it should. Also, the auto-throttle kicked in, and it reduced speed to the correct cruising speed. A-ha!

“Travel To” function glitch: This glitch remains. I tried to “Travel To Descent” but the error message popped up again that said I didn’t have enough fuel. Before this update, I would start with 93% fuel which was definitely enough, and still got this message. However, having to start with 84% this time, it is possible that perhaps it actually isn’t enough fuel - but I have a feeling it is still a glitch. I will do the full flight later today and see if I have enough fuel to make the entire flight. (Edit: it is still a glitch - this happens even with full tanks.)

New flight: Los Angeles to Las Vegas
I restarted a new flight, everything was the same except for the destination. I wanted to try a shorter flight to see if the approach and landing would work.

Descent: Once reaching descent, I turned off the autopilot in the cockpit and turned on AI Control Aircraft. Immediately, the shallow turns resumed. Also, although the throttle was gradually reduced, the airspeed was much too fast with the airspeed alarm sounding throughout the entire descent.

Approach: Despite the turns and the speed, the aircraft actually turned to enter the transition. (Before, it would just fly past the airport and keep on going.) Then, it turned for the approach and got clearance to land. However, it never lowered flaps or landing gear. Also, although it was flying towards the airport, it was not lined up with the runway. I didn’t interfere to see what would happen. It just continued to descend off to the side of the airport and crashed into some buildings nowhere near the runway.

Well it’s an improvement and makes the function semi-usable again. But it still needs work. It’s approximately in the same condition now as it was before they broke it during the Japan update (except for approach and landing).

For now, I will manually do the start-up checklist so I can input the correct altimeter settings, turn on the lights and set up the flaps for takeoff.
For taxi and takeoff, I can use the AI Control Aircraft feature.
After reaching cruising altitude, I can turn off the Control Aircraft feature and turn on the autopilot functions in the cockpit to enjoy the views during cruise.
When reaching the destination, I will attempt to use the autopilot approach function for landing, and if necessary I can land it manually.

I’m experiencing this also. Hopefully they fix it soon

hopefully more will be fixed when they release the world update 3 this Friday…they claim that they will have it back to normal by sim updat 3 according to the bug list on the developmental updates

1 Like

my main problem (outside of the not landing on the runway) is that during an IFR flight, the gauge showing the airspeed stops and goes to 0 during the climb and it makes the plane go in circles in left turns

Turn on the pitot heat.

exactly how do you do that? I just use AI control and I’m pretty stupid when it comes to using the navigation systems in each plane…

Please use this topic for AI Control issues. We want to keep one topic per bug. For those who responded in this topic, make sure you up vote and contribute to this one: