Fenix a320 Flaps and Landing gear not working (TCA Airbus Addons)

My flaps and landing gear on the Fenix a320 arent working, when im on any other aircraft they work perfectly fine, when looking at the flap axis on the controls settings it is working perfect too, aswell as the gear toggle responding as normal.

I am using Fenix version 1.0.6.146
I have tried recallibrating the TCA Throttle quadrant + addons both in the Fenix and the irl process, pushing the 2 red buttons etc.

Cant find any other people talking about this, help would be appriciated :slight_smile:
thank you!

Also, the spoilers, park brk, auto brk, both throttles, eng mode selector and eng1/2 all work, just the flaps and gear.

The MCDU also detects the flaps as moving, but the flaps lever in cockpit and actual wing flaps dont move.



Screenshot 2022-11-26 203634
Screenshot 2022-11-26 203622

Same here, away from home for a few days so not able to troubleshoot further just now.

1 Like

Thanks for telling me, couldn’t tell if it was just me, I’ve contacted Fenix about the issue now too.

1 Like

Do you try a complete reinstall of the fenix? Once I got trouble with just install a new version over an older so I had to delete it and install it fresh.

1 Like

I’m not sure why the gear is not operating - there’s no calibration required for that either in MSFS itself, or in the Fenix, as it’s simply regarded as a ‘button’. The flaps obviously do require calibration in the Fenix, but it appears you’ve done that from the screenshot showing the flaps configuration page. You’ve mentioned pushing the 2 red buttons so I guess you’ve done the factory calibration of the thrust levers, but did you do the full calibration of the add-ons as well, as shown at https://ts.thrustmaster.com/download/accessories/manuals/TCA_Quadrant/TCA_Quadrant-Throttle-addons_Calibration.pdf ? Other than that, if you can see the correct movement of all controls in the MSFS options page, and you have done thrust lever and flaps calibration in the Fenix, then as you say, the only other course of action is to await Fenix’s response.

2 Likes

I’ll try this in a bit, I’ll keep you posted see if it fixed it.

Works now! hopefully the issue doesn’t return, thank you :slight_smile:

1 Like

woke up this morning with same problem with PMDG 737-800. No spoiler no gear no flaps working…

1 Like

Yes for me the PMDG 737 is completely screwed :rofl:

Maybe check that you don’t have more than one physical control mapped to each of the commands.

Having a physical switch on one of your controllers mapped to your gear/spoilers/flaps, by position rather than as a toggle, and you don’t know about it, might prevent it from moving away from that position when you manipulate the physical control you do know about.

As to why it’s just started, that might be because the state of the “unknown” switch has been changed or it might be that a recent update has introduced the “unknown” mapping.

It shouldn’t take too long to check whether this is the cause or not. Good luck

I used to fly X-PLane Zibo thinking nothing is better…Sorry but IMO MFS graphics


with a 737 from PMDG is quite real! I fly it daily doing IFR flights by the book with SIDS and STARS. Flawless VNAV LNAV, ILS DME ARC etc. If I can be of any assistance let me know., I’d be glad to help you.