Finally.....Solved CTD issues... for those of us with < 32 GB ram

Could very well be.
I noticed that was mentioned in a lot of the posts as well.

1 Like

The two errors today:
Faulting application name: FlightSimulator.exe, version:, time stamp: 0x602a34d1
Faulting module name: VCRUNTIME140.dll, version: 14.28.29334.0, time stamp: 0x5fa9a822
Exception code: 0xc0000005
Fault offset: 0x00000000000014b4
Faulting process id: 0x287c
Faulting application start time: 0x01d7079614835838
Faulting application path: F:\Steam SSD\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
Report Id: 374447e6-cc89-4378-96f2-69df513015d9
Faulting package full name:
Faulting package-relative application ID:
[11:59 AM]
this is the new .NET error I received to Application: FlightSimulator.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 00007FFEF70A14B4

1 Like

info: same here e.g. here

Currently no final solution/workaround found.

A question…

Have you MSI Afterburner installed ?

No, I don’t use it and don’t have it installed on my system.

All I know at this point is someone a lot smarter than me said that this is being caused by a software conflict (to the best of their knowledge) and I tend to go with their current hypothesis since they are extremely involved in software development, data centers, etc. etc.

I put in a help desk ticket at this point, and I saw someone else post on the forums stating “it’s not the users jobs to try to figure this out” and I couldn’t agree more. I’ll play the game and everytime I get a crash I will submit a ticket. I’m going to assume their support people don’t look on the forums for issues they need to fix because it doesn’t appear that they ever offer any suggestions or solutions on here.

From what I see this happens to people and it appears random which makes me think it’s server based. It also happens regardless of what settings you have. It happens regardless of where you are flying at, how long you’ve been flying or if it’s 3rd party stuff or not (which it shouldn’t be). They can change things on the server side and we would never know BUT it seems like this appeared after the latest update and MY experience has been exactly this - I never had these errors before. Before this last update I was getting repeated PC reboots until I spent $160 on a new PSU and it cleared it up. I’ve spent money on panels, rudder pedals, Skypark, 3rd party Seminole, Weather Presets, Oculus, and it all seems like a huge waste now.

No, ASOBO does not look on the forum for issues to fix.
They do keep an eye on them though, so they are aware of what is going on.

The only areas that have any bearing on getting issues fixed is the “Bugs &Issues” and the “Wishlist”, because of the voting system.

Putting support requests in to Zendesk continuously may be the only course to follow at this point.

1 Like

Been flying MSFS since I bought it over 3 weeks and had my first 2 CTD today.
Both times ram out of virtual memory so I think there is a memory leak on the last update.

This should not happen with 32GB system memory.
Went into my Temp folder and found over 3,000 files and they were made by MSFS, all dated 22/02/2021

a leak will never stop, but this is not the case.

What is your setting for your windows virtual memory ?

I’m sorry but a 0xc0000005 exception is an application level error in this case. It’s an access violation that occurred in the Visual C Runtime used by FS2020. The app accessed a null pointer.

This is has been happening to me since the WU3. With proper exception handling in the code, this is preventable - although reality is usually far more complicated.

Fortunately, Asobo is probably receiving tons of automated crash reports and has likely already identified the root cause. We have to wait for the next patch.


Yes it happen after last update never had that issue before.
Virtual memory is Initial size 4891 Maximum size 7471

also with 32GIG memory is this amount of pagefile not enough. Possible try a higher max value ( 20 ). You can also try “system managed” , but then you must ensure enough free disc space because of rules for auto-increasment.

This VCRUNTIME140.dll error is the same error that has been causing my CTD’s every session since last patch. I’ve reinstalled the libraries multiple times, no joy. Just broke unfortunately. Hopefully someday they’ll port to DX12 and maybe then it will work. I’m not upgrading to 32GB or RAM because so far none of the upgrades I’ve made have worked. (Over $800 so far)

Well the good news is that I’ve been in contact with MS and they have asked for my dxdiag and msinfo files which I have provided to them after their initial solution of deleting all my c++ redistributables and re-installing their latest version didn’t work.

That being said, having some older PC games that require the older runtime programs/libraries if have to have the older versions for those games to work. So while I deleted all of the old c++ modules some games and pieces of software installed the older mods again when I ran them. I suppose this could cause a conflict since those games installed the older runtime modules AFTER I installed the latest ones on MSFS website.

I did try something cheeky and I haven’t tested it out yet, so the older C++ mods are installed and I went and did a “Repair” option on the latest modules that were installed to see if it might fix the problem. We shall see.

Are you running 16MB ram?
Do you have a custom pagefile set, instead of System Managed?

Yes, running 16GB Ram. I have tried custom page files and system managed. Have tried so many different things at this point I’m losing track of it all.

How big a page file did you set?
I run 16GB ram as well, have very few issues.

I’ve seen a lot of different info on this and I’ve tried different numbers but I saw MS suggested 2GB Min - 48GB Max for 16GB of RAM.

I don’t understand where the title of this thread says “Finally Solved”
comes from.

If “CTDs” are solved, then what solved them?
Who decided they have been solved?

If you aren’t limited by the size of the page file’s drive, I went to 24 and 64 GB.
Those settings work well for me.

you see this because you read solutions for differenc issues.

The normal rule for MSFS is:
you need overall memory 32GIG RAM. So, possible you have to increase your pagefile with a bit reserve to eg. Min:4Gig Max:20Gig. ( possible because for some users ‘system managed’ setting works fine ). ( note: you can also set min:max same, in this case you allways ensure that 20GIG are free usable for memory on you disc )

But with eg. newer updates of MSFS (e.g. London) or possible in big’er airports the app needs more memory , eg. around 40GIG overall memory and therefore some recommendation about : set overall memory to 48GiG.