Flaps not working after installing sim update 7

Please tag your post with #pc and/or #xbox.
#pc

Are you on Steam or Microsoft Store version?
Microsoft Store

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
When moving the L-AXIS Z level on the Honeycomb Throttle Quadrant, the flap lever in the sim is not moving accordingly.
When creating a new flight with engine running on the run way, which set the flaps to 1, moving the
the flap lever in the cockpit moves briefly with the lever on the Quadrant and then immediately moves back to position 1 (1+F in the A320, flaps 1 in all other aircraft).
The same problem occurs when using F6/F7 to move the flaps. This would indicate the problem is not with the Quadrant.
Disconnecting the Quadrant from the PC does not resolve the problem as F6/F7 are still not working either.

Detail steps to reproduce the issue encountered:
Move the level on the Honeycomb and watch the lever in the cockpit move back and flip back to position 1.

Problem persist after emptying the community folder and restarting the sim.

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:
After installing sim update 7 on November 18

Make sure you don’t have multiple buttons bound to the same function or any contradicting bindings
, esp. while one of the bindings might be continuously active (think of the speed brake switch on the warthog… It locks into position and stays active. If that were bound to ‘flaps up’ and you where trying to make the flaps go down with another binding / keystroke it just appears that said binding flat doesn’t work.) - I noticed that if I had a switch active - none of the other bound keys would work. Worth a shot - I kind of got confused today when I was messing with my bindings, and that’s when I noticed this behavior.

I too am having a similar problem after latest update. I have the PC version from the Microsoft store. With say the C172 or the Beechraft Baron , moving the flaps with F5 to F8 keys, the flaps move as expected but then reset themselves to the “1” position. I dare say other aircraft behave in the same way. I have checked all bindings and there are no defintions of flap movement except for the keys mentioned above. Even moving the flap lever with the mouse shows the same behaviour. The flaps worked perfectly before the update! I do use FSUIPC7 for most control but have removed this for my checks. Any suggestions? I have completely uninstalled MSFS before to rectify problems, but this is a long process and I would like to avoid having to do this!

As I mentioned, I disconnected the Bravo Throttle Quadrant from my PC and even with the standard F6/F7 buttons I do get this behaviour.
Also it work perfectly up to the moment I installed SU7…

After seeing some other post about issues with flight controls, it turns out that SU7 set AI assistance to specific pre-sets, causing this behaviour.

Go to Assistance Options, section Piloting and disable Assisted take off and assisted landing.You may have to test various settings to see what works for you.

1 Like

Wow thank you. It was set to All Assistance.

Yeah, that solved also my issue. Thanks!