FLC no longer works in King Air

Please only post bugs that are new in this build, and tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
MS Store

Are you using Developer Mode or made changes in it?

Brief description of the issue:
When FLC is selected with a target speed, the plane just levels out and remains there rather than climbing at the set speed to target altitude. This is new behaviour since SU8 beta HF

Provide Screenshot(s)/video(s) of the issue encountered:
Detailed steps to reproduce the issue encountered:
Set a target altitude. Climb out of an airport set FLC to a climb speed of 170kts. Note that the aircraft will not climb and remains level instead.

PC specs and/or peripheral set up if relevant:
PC i711700k @5GHz, Z590 WiFi, GTX1080Ti FTW3 OC, 32Gb 3MHz RAM, 2TB M2 NVMe SSD

FLC Mode doesn’t work in climb anynore, only descent.

Unfortunately it is only possible to climb in vertical speed mode and this can lead to a stall eventually if not monitored.

Possibly an error with SU8 beta. This needs to be rectified by SU8. A big flaw to get stuck with.

1 Like

If you’re seeing an issue in the beta that you believe is a bug you should report it in the SU8 beta bug section of the forum, else it won’t be seen.

There’s an aircraft systems section, this would fall under.

1 Like

Done. Here is the post in the beta forum. Please vote people.


I voted

Also the suggestion in the other thread about using/downloading WT G3X doesn’t work either. I’ve had it for Months and it makes no difference in the King Air’s FLC issue.


Still broken in mandatory update
Come on MS, how can this have been so easily and obviously broken and not fixed in the last mandatory update???

There are several threads on this issue that you can vote up. Imagine testing every autopilot function on every plane, every time there is an update. That’s a lot of work that nobody wants to do.

Is it the ability to set the airspeed or activate the mode? Do other G3000 airplanes have the issue?

I’ve had some nagging issues where setting VS or FLC just don’t seem to always register the clicks in G1000 and G3000.

I’d try to see if key bindings might help as a workaround. I usually bind the Up/Down AP buttons to my Page Up and Page Down since it’s a general pain with the mouse.

It’s a problem with ascension only, I think. On other planes where FLC ascending works, I can dial in my desired altitude, press FLC, then push the throttle to ascend. I’m not sure about other G3000 planes, I’ll try it later.

If I get some time today I’ll give it a try. I don’t fly the G3000 airplanes too much.

I’m not understanding all the comments about the g3000 or what it has to do with the FLC? In the King Air the G3000 is the navigation instrument. FLC is part of the Autopilot.
Either way, I’m using GTN750 Mod in place of the G3000/1000 and have been for several months now. FLC worked… now it doesn’t

1 Like

It sets the bug and shows activated on the HSI. Aircraft/Autopilot just ignores it and levels off regardless of the speed you set or the increase in thrust.

Like I stated earlier, if you remove the new SU8 “prop_mod…” lines from the engine.cfg file, FLC starts working again.

If you paid me and made it my full time job I would gladly do the work.

1 Like

I assume he meant beta testers… but that reply was hilarious :rofl:

Well, the beta testers are the ones who actually found the issue, and we aren’t even getting paid :upside_down_face:

I actually meant Asobo employees, but I was being a bit sarcastic too. :wink:

Oh OK, even more inexcusable… it wasn’t corrected before the release…So what’s the point of beta testing then?

As far as I can tell it was to make sure there weren’t any major game-breaking issues in the final release. “Game-breaking” may be subjective in a simulator like this but the beta did at least weed out a few bugs before SU8 got released officially.

I got cha. I actually didn’t know the criteria for beta testing.

Mod Edit: Merged into earlier dated report to preserve comments and votes.

FLC Mode doesn’t work in climb anymore, only descent.

Unfortunately it is only possible to climb in vertical speed mode and this can lead to a stall eventually if not monitored.

Possibly an error with SU8 beta. This needs to be rectified by SU8. A big flaw to get stuck with.


Just received update

During climb the FLC autopilot mode doesn’t trim to maintain target speed, instead it just trims to the horizon of 0 degrees nose up. Speed increases, climb isn’t 0fpm either. In descent however, operation seems normal.

In addition, the DA62 still has the incorrect avgas fuel density of 0.72kg/litre instead of the 0.8kg/litre JetA1 value. This is after all a JetA1 powered diesel piston aircraft.

1 Like

Can you repro using Working Title G3X instead of stock?