Flickering/Game goes on-off during a flight is started. NVIDIA GPU

I am not able to play mfs on my oculus quest through link or steamvr. Everything works perfectly on vr until i start a flight. I have tried everything and even got too deep by modyfying and stuff. I am running on a gtx 1070. I am up to date on everything from drivers and even entered the beta program. I have tried everything you could imagine but maybe someone is aware of this problem. Any idea what I could do? I read somewhere that there is a problem with nvdia and OpenXR. Please someone help me i have been messing with everything since 2 days. For the info there is no change if i run with steamvr or standard oculus openxr or revive or whatever

Ryzen 7 2700x
Windows 10, running from microsoft store with my Oculus Quest 2 (on my friends PC mfs runs just fine)

Same issue, only in custom flights. Activities work. VR is good until I click “Fly Now” then it just flashes until CTD.
Quest2, Ryzen 5 3600, RTX3060Ti, Worked well until last world update.

1 Like

Same issues exactly with the original Oculus Rift.

SPECS: Win 10 I7-9700 32gb ram 2070 Super

Saw this in another thread and it worked for me!

Start your flight and turn off all ‘pop out’ screens (such as ATC, weather, checklists, etc.) before switching to VR.

1 Like

For those using Oculus, I too had bad flickering, totally disappeared once I enabled the beta testing in Oculus control panel.

1 Like

This fixed it for me, thank you so much!