Flickering reflections on windshields in cockpit view

It was reported during the beta, right at the beginning in fact. I was one of the people that reported it, and someone else spotted that if your render scale is set to 100% the issue goes away.

I believe that is why the thread was marked as ‘workaround’ but obviously you don’t have the option to do that on the XBOX.

2 Likes

I have the same problem on my Laptop (MSI GE75 Raider 95G - no external monitor)
I actually had this problem a few days back already without SU9.

and now imagine that we already had this bug BEFORE SU8 and it got fixed, only to be reintroduced with SU9. nice work.

2 Likes

I really hope they don’t make us wait that long. There have been hotfixes before as well as sim issue fixes in world updates. Specially after sim update 5. So really hoping this is fixed in the next world update. Unlike others I can use the workaround using 100% render scale since I am on PC. But I should not have to. And even though most of the time I am CPU bound, heavy clouds make my GPU scream and toasty. Hopefully DLSS/FSR 2.0 helps there as well. Only option for me is make it to high which kills the reflections completely. Shame.

These are the very same questions I would like to have answered.
First here on the forums.
And the next time Joerg, Martial and Sebastian are live in a Q &A!

Thought I was dreaming yesterday when the topic of gears and propeller was mentioned and they had to say they do not know of this particular problem, which is present since day 1!!
But this is another topic.

Maybe it would be a good decision to have a constant closed beta-tester crew which receive builds on a daily base. Those guys need to have enough knowledge in aviation and flight siming (hint: F-16 and flaps!). And then have an open beta 4 weeks before the release of a Sim Update.
Next step is then to listen to the testers and get rid of this non-sense voting system.

1 Like

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

When I have Raymarched reflections turned on, they flicker intermittently. This did not occur in SU8.

Detailed steps to reproduce the issue encountered:

Seems to affect all aircraft, whether night or day.

PC specs and/or peripheral set up if relevant:

GTX1070, HDR (occurs whether it’s turned on or off). No graphics mods.

Build Version # when you first started experiencing this issue:

1.25.7.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Why is this tagged as workaround? Setting the renderscale to 100 is not a workaround.
That’s like saying “turn off reflections” is a workaround.

1 Like

It certainly isn’t for Xbox users, who have no render scale.

1 Like

This is precisely what a workaround is, a temporary fix because the true solution is yet to come.

1 Like

and what exactly does this fix?
not sure if you are just joking.

but the issue is flickering reflections at other than 100 renderscale.
setting the render to 100 doesnt fix that problem.

it doesnt fix that problem and it is not a alternative way to achieve working reflections in other renderscales at 100 (which is what a workaround would achieve).

Workarounds come with a compromise because they are not true solutions, that’s the point. You’re working around the problem by compromising on something else (in this case, the render scale).

2 Likes

What is listed as a workaround in this topic doesnt fix the issue, not even temporarily. The issue being a flickering reflection in other renderscales than 100. A workaround would be something(else) that we could do to have working reflections in those other renderscales(temporarily) until the original intended way works.

of course if the goal was just to not have flickering reflections there is many ways you could achieve that. Turning off reflections would be one way, but I wouldnt call that a workaround. But yes setting renderscale to 100 stops the flickering.

1 Like

I’m on Xbox and cannot mess with the scale so what am I supposed to do? No workaround available I guess. :thinking:

1 Like

As a PC user I can confirm, that setting windshield effects from ultra to high solves this issue immediately (render scaling at 100, primary resolution 1920x1080, secondary scaling 1.666666 to 1440).

A fix for this issue is supposedly coming in an upcoming hotfix soon. (sorry if someone else already mentioned it)

Setting windshield effects from ultra to high removes the reflections all together.

Is there a source of an official statement to this?

Yeah, that’s where I saw it. On the most recent dev blog snapshot if you click on Home at the top of this page.

1 Like

Fixed in today’s patch:

4 Likes