Flight Planning. Flight Plan lines slowly disappear in vfr map and onboard navigation (Sept 2021)

Flight Plan Line Disappears

The flight plan line (white line) slowly disappears on the vfr map. It may not show at all on onboard aircraft navigation map. I can watch them disappear leg by leg in the vfr map while my aircraft is at the airport. It usually occurs in less than 10 minutes. I have check some old flight plans that were working and they have the same problem.

I use littlenavmap to create flight plan and export them into msfs pln files. They load fine into world map but when I go and fly the flight plan line slowly disappears in vfr map and navigation map (sometimes it wont show up at all on cockpit navigation map).

If anybody has any solutions or similar problem please let me know.

Aircraft I commonly use TBM 930, Cessna Caravan, Airbus a320.

Updated August 31 in hopes of finding a solution in September.

MSFS steam pc edition fully updated.
Windows 10 Home 21H1
MSFS 2020 Steam edition on 1TB SSD.
MSI x570 Tomahawk motherboard.
AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz.
GPU AMD Radeon RX 5700 XT.
RAM 32 GB (2x16 3200).

Thanks for all your help, Rick.

I had the same problem in the DA-62 using the Working Title G1000 from the marketplace. I uninstalled it. I’m getting better results from the default Garmin g1000. I also installed the latest version of the working Title G3000 from their website and it works fine for me so far.

I can confirm this. I have the exact same scenario where I create the flight plan with Little NavMap, export it as *.PLN file and then load it into FS 2020.

At first I thought this is specific (somehow) to the current flight plan that I am creating, but checking with an older flight plan which is known to have worked in prior FS 2020 versions I see the same effect: right after starting the engine the flight plan line starts to “dissolve” leg by leg. Both on the VFR Map (key V) and in the glass cockpit (I am currently using the Asobo PC-6 with glass cockpit).

Interestingly though the autopilot (NAV mode) still follows the (now invisible) navigation lines, and correctly follows the planned route (by flying exactly on the navigation line, as expected - which can be observed in Little NavMap).

The plan that is known to have worked previously can be downloaded from here (GitHub):

Raw file:

https://raw.githubusercontent.com/till213/Tell-Tours/main/Europe/Switzerland/Steeler/Leg-1/Tell%20Tours%20-%20Zurich%20to%20Locarno.pln

To illustrate:

  • I am (still) sitting on the runway (in LSZH) at point 1, engine started, but not moved an inch
  • However the flight plan thinks I am already at point 2 (the navigation lines did disappear leg by leg, starting from 1).

Now the navigation line seems to have “stabilised” at point 2 (at the point of this writing), but typically the navigation line starts to disappear again “leg by leg” (in advance) as the aircraft is following the route.

P.S. The *.PLN file has been hand-edited (with a text editor): essentially I made sure that the navigation point names don’t have any Ümläuts (just in case), but having spaces in their names (as in e.g. “Grosser Mythen”) seems to have worked, at least in the past (with FS 2020 prior to SU 7). Again, this very *.PLN file linked above is known to have worked in the past.

UPDATE: This issue seems to have been reported a while ago already. So I am not saying that my above linked flight plan did work in the prior SU 6 still - but it did work in around December 2020 / January 2021 (when I did do my “Tell Tours” community flight).

Further observations: I have tried with other aircraft:

  • T-45C (3rd party jet)
  • Aviat Pitts Special (one of the simplest possible aircraft without glass cockpit / map)

But the same “navigation lines disappearance” (leg by leg) on the VFR (key V) map.

For the record:

  • FS 2020 SU 7, Steam Edition
  • Windows 10 21H1
  • Community folder only has one extension installed: mbsim-airport-lszw-thun (“Airport Thun”)

UPDATE: The issue is most likely related to the flight plan itself, or the “complexity” thereof: I just tried with another flight plan (from another community flight, here: [Foot] Canada) and it worked. But that “Canada” flight plan only contains a dozen or so waypoints (and only one “custom” waypoint).

So the issue could be related to one of the following:

  • The number of waypoints
  • The number of “custom” waypoints (not located on top of some known “navigation station” (?) or airport)
  • The distance between the waypoints
  • The names of the waypoints (I will try to also remove white space now…)

What I tried so far, when editing my current *.PLN file with a text editor:

  • Removing all whitespace from waypoint names
  • Changing < FPType > from IFR to VFR
  • Making sure that the < DepartureLLA > has the exact same GPS coordinate < WorldPosition > like the first waypoint
  • Switching < DeparturePosition > from “PARKING 2” (the aircraft is indeed properly placed “cold and dark” at the parking position number 2) to “10” (= runway 10)
  • Changing < DepartureName > and < DestinationName > to match exactly with the first and final ICAO code (instead of some descriptive name)
  • Addind an extra < SpeedMaxFP >-1< /SpeedMaxFP > entry to each waypoint (which wasn’t exported by Little Navmap, but which I saw in the flightplan from [Foot] Canada)

(Note: I deliberately added a whitespace here in the < tagnames >, otherwise the forum software does not show them)

To no avail: the legs kepts disappearing one by one (until about 1/3 into the entire flight). Eventually I had the same structure like the (working) flight plan [Foot] Canada, except of course different GPS values and names for the waypoints. And I have way more waypoints (and they are closer together to each other), which might be the issue in the end (?)…

All the tests were done with the stock Asobo PC-6. Specifically I do not have any “Garmin”-related addons installed (the only community addon is the “Thun” airport - all other addons are payware airports and aircrafts from the in-game Marketplace).

Thank you for all your input @Steeler2340. My little navmap flight plans are still disappearing. Even when loading a flight plan it takes several load tries to get the departure and destination runway choices to show up.

Think I will create some very simple vfr flight plans as test flights.