Flying iron spitfire canopy

Um, for some reason, I can’t close the canopy in the spitfire. When I hover the mouse over the pull bar area, I get the little hand pointer, but it doesn’t close the canopy.
There doesn’t seem to be a keyboard binding for it that I can tell.
Anyone else have this problem, or can someone tell me something I don’t know?
Thanks in advance.

Make sure you have the door pulled up and shut before trying to close canopy


Thanks, fixed. I stumbled on closing the door as I was clicking around the cockpit, but never connected it to closing the canopy. Im used to flying the DCS spitfire, and the door is always closed on startup.
Thanks again.

Helped me too. Just got the Spitfire. Canopy not working… Searched the forum… Door? What door? Oh. That door. Once you see it, it is obvious.

Trying to close the canopy got me lots of takeoff practice.

1 Like

Hi I can’t find a way of closing the door I clicked everywhere anyone no if there a video showing

Been a while, but iirc, it is low left. I don’t have a video to show. If you still can’t get it trying low left, I’ll take a screen shot (on a long 8 hour haul with dc-6 atm, so it won’t be until morning), but if you don’t get a better offer before, I’ll do it.

Ok thank I’ll look in morning

I’m on Xbox and don’t do anything when I click

AFAIK Spitfire pilots took off with the canopy open to help them escape if it crashed on take off, therefore when when you close the door it does not fully close, this is to stop the canopy sliding forward in case a bump or something forced it to close and potentially trap the pilot.

Therefore to close the door first click on the door at the bottom near the hinge then when it has shut, you need to click at the top of the door again to lock it, then the canopy will close.


Yeah the problem is that bottom hinge does not do anything on xbox. The upper canopy can slide back and forth still though, so only and issue if you start cold and dark.

you do have to close the door and then latch it. check the entire door jamb or frame to close and then also click in the black and yellow latch handle to latch it before closing the canopy - there is a strap handle on the canopy to click on that activates it - in this vid I close the door right away but the canopy stays open until after takeoff and the gear is up and the prop and mixture are set for normal flight

Yeah it’s an xbox specific issue

1 Like

ahh - I missed that.
They’ll get it worked out then - matter of time.

1 Like

It’s going to take 3-4 weeks before we see update for it

Apparently it was submitted a while back (the patch) but Ms/Asobo have been slow, hopefully they manage to get what was meant to be yesterday’s market update through soon

Over 3 months from your post its still not fixed… Are you sure its getting sorted on xbox?

I bought the Spitfire and have the same issue on the Xbox as reported above. Also engine damage only results in some smoking - nothing more than that on Xbox.