For What It's Worth - Best Perf I've Had w/ V-Sync ON

I have an i9-9900k with an RTX 2080Ti and I always run FS in 1440p… I must say I haven’t had consistently good performance, as thousands of you have already stated.

However, I read in forums to try V-Sync ON and limit to 60fps – which goes against everything I’ve been taught in other games, but this works so well. Even when I’m on ULTRA settings and only getting FPS in the 30s it’s silky smooth and never notice it.

So try Vsync = ON and I think you’ll get a much better experience.


I’ve been using v-sync on from day one @60fps @1080p, settings between ‘High End’ and ‘Ultra’ across the board - had no problems at all. One CTD since release.

i7 8700k@3.70GHz
GTX 1080 8GB

Good to know… I never use V-Sync since my PC is “top of line” but it’s def helpful in this sim.

I think you are on to something here. Been running with Nvidia CP set to 30fps and indeed the GPU never goes above 80%, the CPU however would sit around 75 then spike to 100 and frame rate would tank.
With the game Vsync on and 60 fps both the CPU and GPU are near 100% all the time but the drops seem less severe. This is on a lesser system, i5 6600 and Nvidia 1060.

thanks i’ve been saying this all day lol
it seems we found a good “bug” :rofl: :joy:

I even got OVER 60 fps when limiting to 60… so weird hahaha

1 Like

For me, v-sync on I get less than 30fps on both the 30 & 60 settings.

If I switch it off, I get 65fps. No idea what’s going on

I will try this, although my FPS are fine normally 30+ the smoothness others speak of isn’t that same for me. It’s not bad but it’s not butter smooth.

I get the same, with v-sync on it gives me terrible FPS.

your spec pls…

I7-4790K 4GHz
GTX 1660 Ti
Win10 2004

I should add that I have FPS limited to 60FPS in the Nvidia Control Panel since alpha 4.

I tried Vsync on (have gsync monitor) and while FPS didn’t seem to change much the scenery was loading in more consistently for me.
Going to stick with Vsync on for now, thanks OP

1 Like

You’re most welcome.

Tried it with the 60fps setting in the control panel turned off. V-sync worked fine! Must have been a conflict

No difference for me - Settings between High End and Ultra, frames consistent at just above 30 with both settings;

i7 8700k@3.70GHz
GTX 1080ti 11GB