FPS drop every 10-15 seconds

Constant FPS drop to around 15FPS every 10-15 seconds. This happens even in main screen. I also noticed that the CPU usage drops to 10% when this happens

I seem to be having a similar issue all of a sudden the last few days without changing anything on my side. I notice it in VR, so I thought it might have to do something with a SteamVR Beta update. Sound gets interrupted and the system has a hickup every 10 or so seconds but sometimes a lot more. Everything ran really well up till now, nothing seems to help to get this problem away.

I reinstalled the sim and that fixed the issue. But it’s back now
I hope it gets fixed in the next update

what are you cpu and gpu thermals, looks like thermal throttling sort of

At least on my machine this isn’t the case, everything is well below 70C. Somehow it all started a few days ago. Might have been an update to a software component that is ruining things suddenly, but I cannot find any serious spikes using the task monitor. I tried turning off HAGS but that made nearly no difference. It’s so strange because everything was running perfectly well.

Im not sure if these developers know how to implement a HOTFIX yet. This Flight sim seriously serioulsy needs one. The last patch completely broke the game and there is no way to fix it but to wait for a new patch. Well I have been waiting for over a month now for a fix to thos mess and the update that was supposed to arrive has been pushed back even more. I understand they want to make this patch but if this patch does not fix the low fps I will lose it. This is why updates should be rolled out in stages, so in case something like this happens, we can go back to a previous build that worked just fine. Being stuck flying at 15 fps for a month when before the update I was getting 45+ fps, this is an absolute disaster. If anything, I just wish the devs would get serious fast about implementing stable performance hotfixes. Every time I fly I get more upset because I knpow what this sim used to and SHOULD be like and waiting this long for a proper solution is plain stupid.

My thermals are normal. I checked it

So I installed a second copy of MSFS on my PC through the Microsoft store and voila! No issues. The game runs smoothly.
This makes me wonder if the issue is with the Steam version of the simulator.

Good :ok_hand:

i have ms store versio as well and have had just 2 ctd during 250h and otherwise its been working flawlessly.
still kinda weird if steam versio would cause more problmes but who knows, cant tell it by myself :sweat_smile:

I know right! It’s weird that the steam version has issues and not the Microsoft store version

Ok, I found the source to my sudden performance issue. It had to do with the wireless connection performance while using Virtual Desktop on the Quest 2. Rebooted my router and the Quest itself and that got rid of the problem. So nothing strange going on with the sim.

Everything is smooth again. I’m using the Microsoft store version by the way.