Freelook Mouse Control is Gone

For the first time I am unable to use the Freelook option with the standard right-click mouse button access. There doesn’t appear to be any issue with the mouse - I am able to access every cockpit control and menu - it just doesn’t respond anymore to the freelook initialization. Now I can’t move freely around to get the best angle of view (it has failed both in the cockpit and externally) - this is a problem for me and has basically brought a halt to flying.

I have checked all assignments (they have not changed and the controls options system still detects the button-press), I have restarted flights, restarted the sim, rebooted the computer, changed aircraft, everything I can think of… no response. I can use the assigned external camera keys (most of which are assigned to views I have no use for) but freelook does not respond. The view just stays in the same place it was when I left the external cam last time.

Any ideas? I use the Thrustmaster T.16000M with TWCS and the Razer Viper Ultimate mouse. I’ve never had issues before.

Exactly the same problem. Same joystick and TWCS. Microsoft bluetooth mouse. Used to work perfectly and now I cannot use FS2020 at all anymore.

I have had this same issue since the second SU5 Hotfix. Glorious Model O mouse and Honeycomb Alpha Yoke. I’ve been through every possible fix with no results and no one until now reading your post seems to have the same issue. The sim is still flyable but cockpit views are limited to up and down arrow sliding views. Everything exterior works fine. Hoping that the next SU cures this or I will be doing a reinstall of the sim! Sorry I could not be of any help.

I actually did a full reset, uninstall and full re-install of all 128 Gb of FS2020. Did not help. It seems whatever is corrupted is in the cloud settings so you never get rid of the problem. It seems FS2020 is iretrievably broken. I find it unplayable now as I relay on Freelook a lot in the complex cockpit of a A320Neo

1 Like

Did you try resetting the mouse control scheme to default? that tends to fix bad assignments etc.

Restore TWCS profile to default or remove freelook from TWCS profile and save changes.

Go to options > controls options > mouse
select default profile and save changes
image
Source https://forums.flightsimulator.com/t/buttons-and-switches-dont-work-with-my-mouse-after-update-5/428591/3

Also Try “mouse wheel button” (mid-click)
image
Source https://forums.flightsimulator.com/t/cannot-steer-aircraft-when-using-mouselook-right-click/426665/2

Resetting the mouse to default was step 1. I am in about step 200. When you have reinstalled the whole 128Gb three times you are getting close to where I am

1 Like

I have the same problem, and it started 2 actualizations ago!
Now I can’t play the game anymore, outside the airplane the camera work without problem, but inside the cockpit, didn’t.
Did all this workarounds, and even full instalation, how can we get a fix???

Resetting to default is when you don’t know what to do.

Any of you checked home cockpit mode ? This was march 2021,

Just found the solution!! There is a feature called “home cockpit mode” (under general, camera, cockpit camera) which has to be turned OFF, otherwise you can’t look around in the cockpit.

1 Like

I was the OP on this and resolved my issue through info from another post. In my case, I lost both cockpit and external Freelook control. This is what it took to resolve it:
Imgur
Without the addition of an axis to the right-click mouse command there was no more viewing function. How I made these updated assignments:

  • Copy the default mouse profile (unless you’ve already made your own version) so you can edit it.
  • Find the Cockpit and External Camera assignments.
  • You will find the Freelock modes already assigned to right-click.
  • You will need to add assignments to the Yaw and Pitch Axis for both cameras

The only way I found to do this was to set the assignment from the detect mode. I held down the right mouse button and carefully moved it in the horizontal mode, then the vertical mode for the other. This is very difficult to control - many times the Options system picked the wrong combination on the axis, so I immediately deleted it and kept trying until I got the assignments you see above. Now, the Freelock views work again.

2 Likes

Yeah I used these “AXIS” things to bind the cockpit camera to keyboard cursor… my touchpad is not handy as MSFS-mouse… and indeed, MSFS should simplify these key and mouse bindings. Just give us a few templates, for handy couplings. If they can do AI for building colors, it must be possible to put a more intelligent control settings interface… Up and down, left and right… how difficult can it be. Now we have to use the Search and think of the right keywords ourselves… “yaw axis” ? :grin: simmer knowledge required !

Did everything here, yet, no solution :frowning:
At least, you guys tried to help me, thx!

Freelook mode was gone for external and internal view for me, I tried everything that was suggested above. I was able to get the external camera freelook to work again by resetting the mouse profile to default, nothing worked for the internal camera freelook though… Weird issue!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.