[Freeware] Peeyem, a simple package manager for Microsoft Flight Simulator [v0.6.0]

My bad. Version 3 fixed it! I can now direct to D. Thanks!

Gr8. Have fun with it.

Can’t get it to run. Each time I click.exe it says I need to install Net 3.1, which I did?

The application does not generate a message like that so something must have gone wrong during the installation of .NET. Is there a UserData directory created with a log file in it? If not, Peeyem hasn’t started yet because it’s the very first meaningful thing it does.

Hi
Where can I get instructions for installation and linking of items in the Community folder?
I am looking forward to using it
Regards
Charles

@ChasHill, you should not worry about the technical aspects. Please have a look in the Manual.pdf file where I’ve tried to explain how Peeyem works. Let me know if it is not clear enough.

What is the link for the Manual.pdf as I cannot find it

Regards

Charles

It should be in the archive you downloaded. It just checked, it’s there. However, as I explained earlier, there was a version on GitHub for 15min. without the manual because I forgot to add it. I should have increased the version number… Please re-download the archive.

Not sure what doing wrong?

Does this work with symbolic links? I store stuff on my D drive as the c drive is an ssd and is getting full and I create a link to file in the community folder.

It seems that sometimes a problem occurs during the installation of the .NET Core runtime (Beware, Techtalk Ahead).

The solution seems to be to re-download the runtime.

Also, make sure you fully extract both Peeyem (to a final location) and the runtime (to a temporary location) before running them. Don’t simply open the archives in Explorer and run them from there.

Yes, you can keep the Community and the Warehouse package on separate disks. Please read the manual.

Try downloading the x64 version instead of the x86.

Thx. Didn’t think of that.

Thanks all…I have tried everything you suggested but no luck.

In the runtime, there is nothing to run. It is just u0-u19…no .exe

I have the runtime in a folder that I unzipped to…is that correct…or do u0-u19 have to be outside of a created folder?

I just downloaded the x64 .NET Core installer.

You have to execute it, not unpack it. The installer will download and install the necessary binaries for your system.

Brain cramp…been unzipping too many msfs add ons …lol.

x64 worked. Thanks so much!

Hi there
Thanks very much for this package. I have installed it and have pointed the program to my 3 locations, office, community and package warehouse.
The problem is, when I click on refresh, it shuts down the program. I cannot seem to load it up again afterwards.
Alternatively, if I point the program to my 3 locations and I don’t reset, and simply click on display package warehouse, it says loading packages at the bottom but the “waiting icon” stays there and the program just hangs. Please can you help? I have moved all my community folders into the package warehouse folder.
Thanks

Sounds like an unhandled exception in the code. Can you please check the log file (or send it to me)? It’s in the UserData folder.

Hi Sardaukar888, I would like to send you my log file but it doesn’t allow me to send anything other than jpg on this forum.

I have sent you a link to my google drive where the file is at.
Please can you take a look there?

Thanks