Freeze and CTD in VR -solved-

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.


Brief description of the issue:

When flying with VATSIM and without VATSIM in VR (HP Reverb G2) I get a freeze and CTD randomly in the middle of the flight at latest. Happened with Fenix A320 and multiple times with PMDG 737-800 while preparing the aircraft.
The Sim freezes for a couple seconds and then I get a CTD.
Happens in DX11 and DX12 but does not happen in GA Planes… EDIT: Happened also with default 787-10.
Somehow VFR flights with C152 etc. are fine.

Provide Screenshot(s)/video(s) of the issue encountered:

Not possible

Detailed steps to reproduce the issue encountered:

Start a flight in VR…

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version (Learn how to find your current graphics card driver version):

NVIDIA 536.67

PC specs and peripheral set up:

AMD 5800X3D - G.Skill Aegis 32GB DDR 4 RAM - NVIDIA RTX 4090 - Installed on M2-SSD - Windows 11 - Happens in DX11 and DX12 - HP Reverb G2 with new cable

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:


Build Version # when you first started experiencing this issue:

Moved to Tech Talk which is more appropriate whilst others help you troubleshoot :+1:

1 Like

Meanwhile I suspect VSR (GitHub - daveblackuk/VSR: Vatsim Radio (VSR) - MSFS 2020 toolbar app for VATSIM) to be the problem:

Thats what I wrote in their discord channel:

"Hi, I am afraid VSR causes CTDs on my system.
I am using VSR only when flying in VR (HP Reverb G2)

My system: AMD 5800X3D - 32GB DDR 4 RAM - NVIDIA RTX 4090.

*Yesterday I tried to fly from LFKJ to LFKB and had several CTD. The Simulator freezes for a couple of seconds at random flight phases and then happens the CTD. I did not suspect VSR so I changed some settings and tried 2 or 3 times again → CTD. *
When I did not start VSR I was able to complete the flight.

Same today with EDDC - EDDH.
*Just when I did not start VSR I was able to finish the flight. When VSR was running I sooner or later had an CTD. *

Is this problem known?

It would be sad because VSR is really helpful and I appreciate the hard work"

Obviously VSR was the problem.

The DLL file was not correctly installed.


How do you install the DLL file correctly?