Freeze no CTD on every flight

Happened twice to me yesterday, I don’t know about the rest of you but for me it’s 100% bound to happen if I start a second flight after a first one, no matter what its always at FL290/310 during climb on a second in a row flight, with or without mods using any plane. My pc usage is around 50% at climb so it’s not its problem. So, a 30-60 min flight, back to menu, starting another one will be a 100% freeze at some point, but after restarting I can do LFBD-KSEA without a single mini freeze. (Except at approach ofc :stuck_out_tongue: )

Something like this happened me too just moments ago. Freezed for 10 seconds, hearing only sounds and GPU started to idle. I did only change cockpit view to external view and freezed. After 10sec freeze, everything back to normal and flight continues.

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

randomly freeze up to 1-2 seconds in every flight

If relevant, provide additional screenshots/video:

I’ve been struggling with this painful problem for months now. All I can say is it’s VERY difficult to work out what’s happening.

Common themes are: freeze, no CTD; typically happens around 28,000 Feet - but can happen a few 1000 feet lower or higher; Always after take off - once I’m above 30,000 feet it’s never happened for the rest of the flight. MSFS is not causing overheating or stressing my GPU or CPU (I’m not overclocking or pushing resources).

I’ve tried - EVERYTHING. I really mean it. I’ve reinstalled Windows 11 and MSFS several times. I’ve obviously tried it clean and with different addons. I’ve tried a different graphics card. All drivers are up-to-date - I tried a variety of different NVIDIA drivers. I’m on a new 2gb SSD. I’ve tried BIOS setting changes. Rolling cache settings. DX11/12 and all manner of graphics settings. I’ve tried limited frame rates both in MSFS and externally. NOTHING HAS WORKED.

ONE thing that seems to have at least reduced the occurrence of this freeze is disabling Live Weather after take off. It’s hard to tell, because it happens so randomly (it seems). But most flights if I disable Live Weather after take off and only enable it once I’m above 30,000 feet the freeze doesn’t happen. The reason I tried this was because I saw someone else mention that MSFS did weird things to the temperatures in Live Weather around that altitude. I don’t think it’s really a fix, but it seems to help reduce the occurrence rate.

I’ve honestly never encountered a problem like this in 30 years of computer gaming - I’ve always been able to solve an issue, but this one defies me.

Oh and if I fly around in helicopters or light aircraft or even a King Air - but below 28,000 feet, I never get the freeze.

Ok well, that’s my story. Glad to see there are others out there with the same or a very similar problem.

I’m still getting them occasionally. A couple are reproducible - see my posts earlier in this thread on my flights from Batticoloa (VCCB) to Columbo (VCCC) and Lukla (VNLK) to Syangboche (VNSB). I’ve just updated them with v1.37.11.0 data to reflect that I can get the sim to freeze every time I load these two flight plans & fly them.

1 Like

Same here on my end both on 2 PCs and On 2 of my Xbox series X so that’s 4 different devices I’m using all having the same issue and yes it’s above flight level 30 when it happens . This seems to be traffic related, when I start my flights with live traffic off, I have no freezes , it’s been off and on and I tried with mods and pure vanilla . This is certainly an issue that needs to be addressed and looked at . The game freezes and never can recover I have to start from scratch all over . This is beta and non beta su 14 .

1 Like

Ok. I’ll investigate with turning off live traffic as well. At this point, I’ll happily sacrifice major aspects of the sim just to get some reliability back. I forgot to mention I stress-tested my PC and it was rock solid - so I’m pretty sure it’s an Asobo thing.

1 Like

Yes i have tested every single aspect about this situation. USB power not sleep mode , monitors not sleep mode , keyboards , mouse’, you name it and I thought maybe setting the transponder to TA only might do the hack but no dice . Fresh installs and so forth . Like I said , 4 different systems 2 high end PCs and 2 Xbox Xs and it happens always at flight level 290 to 310 . All kinds of aircraft. Big airliners all the way down to a TBM and it will freeze up . The only culprit I have found of so many hours and weeks of testing this was down to live traffic . Give it a shot . Turn it off and after cruise , if you get that far , turn it back on . Best regards to this bug that is certainly on Asobo side .

1 Like

My experience, as you can read in my previous post, is very similar to yours. The only difference is that it always happens to me when I’m at the airport, almost never in flight. Other than that, it’s really frustrating. I’ve also tried absolutely everything, I’ve been having this problem for years.

1 Like

It happens to me almost every flight at exactly the same place. These flights are identical. I start up a flight with departure and destination the same: the default runway at EGLC (London City). I fly straight out westerly direction for about 6 or 7 minutes. Then make a U turn and enter the landing aide squares in the sky and follow them down to land. At about 1 minute to touchdown the screen freezes. I wait 10 seconds and it unfreezes and all is well.
By the way, I am getting from 60 to 80 fps the whole flight. I have no traffic turned on. I am using the payware version of EGLC. This airport is right in the middle of London’s high rise buildings, so heavy scenery area.

4070 gpu 58003DX cpu 32:9 double wide 1440p monitor. DLSS Quality. Frame Generation ON. Both LOD’s 200. Render preset Ultra. fps on runway before take off: about 75 to 80. It can get down to 60 or so during flight. (If these fps seem high, it’s because FG doubles the frame rate).

What I’m seeing in flight are slight stutters each time live traffic is injected. Eventually the entire sim freezes? Turning off live traffic helped me. This just started for me over past several months?

Hello everyone,

I’m revisiting the freeze issue I’ve been experiencing which I’ve previously discussed here.
I’ve now used Process Monitor to delve deeper into what happens when the freeze occurs.
During the monitored freeze event, Process Monitor logged multiple file system activities from FlightSimulator.exe. Most notably, there were repeated attempts to access files related to input device drivers and language packs that are locked. Here are some key patterns observed at the freeze point:
The freeze coincided exactly with the first instance of the file input.PNF being marked with the status “FILE LOCKED WITH ONLY READERS”. This indicates that the file was accessed while it was locked and available only for reading.
Frequent access to directories and files under C:\Windows\INF and C:\Program Files\WindowsApps\Microsoft.LanguageExperiencePackes-ES…, which seem to be related to input configuration files (.INF and .PNF).
Here is the first occurrence of the event:
Time:19:06:43,4643059 Process:FlightSimulator.exe PID:11124 Operation:CreateFileMapping PATH:C:\Windows\INF\input.PNF RESULT:FILE LOCKED WITH ONLY READERS DETAIL:SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE_READ

The timing of the freeze aligns precisely with these locking activities, suggesting a potential issue with how the simulator interacts with specific locked system files.

Might be worth logging this with Zendesk rather than just reporting it on the forums, particularly if the same thing happens in the main release rather than the beta.
INF and PNF files are used as part of driver installation, which is an odd thing to be happening whilst the game is running but certainly not impossible. It would be worth looking in the event logs to see if you can see unexpected device activity which correlates in time, though as I recollect from trying to debug such issues its very hard to identify USB devices being manipulated. Activity may not be directly in the flightsim exe itself, as a lot of this sort of thing happens in system processes, and this could also be a conflict with something else running. I’m pretty sure I remember threads about issues caused by USB devices re-discovering and re-installing themselves frequently. Having looked previously, its also of note that the flightsimulator process does absolutely huge amounts of file I/O in normal operation and you would assume that any interruption or lock in the file system its using is likely to cause a stutter (thread locking) or crash.

Thank you for the detailed suggestions. I have checked the system event logs repeatedly during instances of the freeze, but there appears to be no recorded activity that correlates with the freezes in MSFS. This has made it challenging to pinpoint the exact cause through those logs. I appreciate your advice on logging this issue with Zendesk for a more formal review. I’ll follow up on that and see if it can provide further insights into this persistent issue.