Frequent crashes with Reverb G2

Hi all,

A few months ago I purchased a Reverb G2 (V2), primarily for use with MSFS 2020, but also for playing other VR-games on SteamVR.

Since day 1, I’m experiencing frequent freezes/crashes of the headset (further explained below). I’ve been fiddling with all kinds of settings to get it fixed, have had a replacement headset and a replacement cable from HP, reinstalled my laptop, etc, but the problem persists.

The most frustrating part (aside from the freezing/crashing, obviously) is that I cannot seem to be able to pinpoint what exactly is wrong. I can’t find any logging in Event Viewer or elsewhere that will help me understand what’s wrong (other than generic messages like “DWM.exe” or “nvlddmkm.sys” errors).

So, I’m hoping there’s someone on this forum who might have suggestions that’ll help me locate the problem, so that I can fix it, or even have peace with it…

I use a laptop for gaming, a Lenovo Legion 5 Pro (AMD Ryzen 7 5800H, NVidia RTX 3070 Laptop GPU, 32Gb, Win10, full specs can be found here). The laptop does not have a DisplayPort connection, but it does have two DP1.4 compliant USB-C ports. The system is set to use the Windows Mixed Reality OpenXR runtime (preview version).

I’ve fiddled with all kinds of settings, nothing seems to work. HAGS on/off, setting a custom resolution of 50% in OpenXR Developer Tools, MR on/off, USB power suspend is off, etc, etc…

My findings so far:

  • The headset works great, until it doesn’t. Freezing/crashing occurs without any warning, and in multiple games. Sometimes I can play for fifteen minutes, sometimes I don’t get past a load screen.
  • The laptop will run any game I install on it without breaking a sweat, even on the highest graphics settings, for example, Control Ultimate Edition with all settings maxed: no problem. No Man’s Sky: no problem. MSFS 2020 (everything ultra): no problem. I can fly for hours in MSFS without VR.
  • Games I’ve tried in VR, and where the headset will crash: Wanderer, Half Life:Alyx, MSFS 2020.
  • One game where it almost never crashes: Beat Saber.
  • The freezing/crashing is not-reproducable, except when I use the Flashlight/Torch functionality of the headset: almost instant crash.
  • I’ve tried several USB-C to DP adapter cables, crashes will occur in all cases. The adapters I’ve tried have been reported by other users as adapters that they use succesfully with their headset (Cable Matters, Wentec/Yiwentec)
  • It doesn’t matter which USB-C port I use for the display feed, both yield the same result.
  • It doesn’t matter which USB port I use for the USB cable of the breakout box (be it one of the ports on the laptop, or on a powered USB hub).
  • I’ve had the problem in Win11, did a clean install with Win10, didn’t help.

I’m open to all suggestions!

Thx,

Jeroen

I’ve been using my G2 for about 2 years and it’s been pretty much trouble free.

My Rig

Processor Intel(R) Core™ i7-9700K CPU @ 3.60GHz 3.60 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor

Edition Windows 11 Pro
Version 21H2
Installed on ‎2/‎26/‎2022
OS build 22000.588
Experience Windows Feature Experience Pack 1000.22000.588.0

NVIDIA GeForce RTX 2060 Super with 32g memory
G Sync Monitor: Dell 27 Gaming Monitor - S2721DGF

Internet Speed
230.9 Mbps download
32.5 Mbps upload

I’m genuinely happy for you that you are using your Reverb so succesfully! However, I fail to see how this will help me with my request?

1 Like

I just thought it would help narrow down the problem. I don’t think it is the G2? I may be wrong…just trying to help.

Have you contacted HP? Going by the Forum the vast majority of us have no major issues, it’s possible you have a defective unit.

I have; the headset-unit has been replaced, and the cable. Problems not solved. I don’t think the issue is with the Reverb, most likely it’s “something” in the laptop i’m using, be it hardware or some (obscure?) setting.
I’m running a full diagnostic of the laptop right now, and will be contacting Lenovo support soon. Perhaps they can point me in the right direction.

Oh, that is a bummer! Good luck hope you resolve