FSDT GSX PRO isn't showing up in Toolbar Menu in game

For whatever reason, my GSX toolbar isn’t showing up after installing GSX PRO. The engine seems to be loaded okay, but it appears that the GSX icon isn’t popping up on the toolbar for whatever reason. Has anyone else encountered this?

Yes I noticed this yesterday so tried an update but still not there.

Current flight doesn’t need it (CJ4) but I’ll try re-installing later on and see what happens.

It happens to me on every aircraft I’m not sure why. I guess I’ll try to get into the forums I just hate the thought of having to get approved though.

Okay, an update didn’t work so I completely uninstalled it, did a system cleanup to remove any leftovers and re-installed. Using the FBW A320 it’s now working okay. However the automatic start still doesn’t work so I manually started the app once the sim was running.

Incidentally I read somewhere that rather than using the GSX Update tool it’s better to go for the Installer.

Not even that fixed it, maybe I’ll try a clean reinstall. The GSX update tool seems to be crashing after like 2% as well. :confused:

Is the GSX addon linked in FSDT installer? I mean, do you see a pair of symlinks in your Community folder? If it’s not linked click on the left most button on FSDT installer to do it. This will create the symlinks.

GSX needs that to show the toolbar and then the executable app running to use the toolbar features as well. Currently the app is added to MSFS exe.xml but this normally fails to launch the app. I use FSUIPC to launch the app instead. You can also launch the app manually.

Cheers

I am having an issue with GSX PRO menu it says file option instead of services needed


I assume the “Relink” button? I clicked it, but it just stays the same. The folder also points to my other hdd as well, so I’m not sure why I don’t have the symlinks? Also, GSX keeps telling me to udpate it…

Yes, that´s it. This button needs to turn green once the symlinks are properly created at your community folder. Then the toolbar will be seen by game.

I would suggest you to uninstall GSX and also the FSDT addon manager (this one from Windows control panel). Remove any residual GSX symliks that may be left in your Community folder, delete the files at the FSDT Addon manager directory as well and start a fresh install using the universal installer. A new install will link the addon directly, so you would need no more manual tweaking other than the configuration inside GSX to exclude any third party airport if you need it.

Cheers

Hi there, i have the same issue where my menu only displays the following. Does someone know how to solve this?

Mine is a different issue, I’d recommend starting a new thread.

I was unable to get GSX to show up, I may just have to go over to FSDT and ask over there. They at least accepted me!