FSHud always optns

I downloaded and installed FSHud ATC. Now it starts everytime I load MSFS. I don’t want to use it on every flight so how can stop it from loading?

Do you know how to find and edit your exe.xml file?
If so, check for an entry there and remove it.
Backup the original first!

I’ve looked and can’t find the exe.xml file. I did find FSHud hiding under services in task manager. From there I can shut it down. I’ll post a question on their discord channel. Thanks for your help.

If you haven’t found an answer, the exe.xml file in a default MS Store installation is located here:


1 Like

Here’s the answer I got from their discord channel:

“The FSHud app stays running in the background outside of the sim. Just close out of the app and it won’t “start” with the sim. You can tell if it’s running by looking in your taskbar tray.”

Hi @NonstopOyster0,
I don’t have this app installed, so this is just speculation, but perhaps the app configured itself to start when you log in? Have a look to see if it is included in Windows Settings | Apps | Startup.

Thanks, but that’s not it. The FSHud.exe is found in task manager under the “details” tab. From there you can shut it down. If you leave it there, it will start on every MSFS flight even when not wanted. I’ve not found what triggers it to start. If you shut it down before starting MSFS, all is fine and you can fly without it.

Go to

In notepad open file named exe.xml

Take a screenshot and paste into topic

1 Like

As TenPatrol says, can you post a pic of your EXE.xml file?

Most external self starting MSFS apps are started by the entries in this file.

1 Like

Here is a picture of my MSFS Local Cache. There is no exe.eml file there. I think when you open FSHud.exe (which is in Program Files) it installs a copy in the background which can be found in Task Manager in the details tab. FSHud assumes you want to use it on every flight. It can be shut down in the Task Manager.

If it is not being started within the MSFS exe.xml file, it might be starting as a task. To check this:

  • In the Start Search Box, type “Task Scheduler”
  • Within Task Scheduler Library, see if there is an entry for FSHUD. It would prbably be above the MicrosoftEdge items shown in the screenshot below.

If it is there, right-click the item & disable it. You can always re-enable it if you want to later on.

When you close FSHud application main window, it clearly and briefly shows you that application is still running and it can be accessible via Tray Icon.

Then clicking on Tray Icon you can open it or completely close by clicking on “Exit”:

Therefore - if you don’t want it to run, just exit it via tray icon.
There is nothing common with MSFS.exe.xml and simulator start dependency.

The reason that application runs and needs to sit in background is because it can be also used for P3D and needs to detect P3D process or MSFS process in order to scan it’s files before it was completely started.

Besides that, the application doesn’t start automatically on windows startup.

Thanks for that information. The OPs original question is still unanswered though - what is causing the FSHUD executable to start in the first place? Do you happen to know?

1 Like

There was nothing started in the first place.
The FSHud was just started once and keeps running between different starts of MSFS.

Ah - so the OP originally started FSHud manually, then left it running after exiting MSFS, so it was already running when MSFS was restarted again. Makes sense. Thanks for the clarification. :slightly_smiling_face:

1 Like