FSX Import Showcase

It’s a .NET Core 3.1 project, so you would need that. I think it’s included automatically in VS 2019, otherwise you can download the SDK directly from MS and run the command line tools.

Will try that.

My friend made a exe from your code and we had to make some changes. For some reason your file would produce links with double \ in the links.

So, I realized that running your content through the project package setup will build some of the necessary .json files. I’ve been messing around with that X-Wing project from FSX some, and managed to build myself a full project that will appear as a third party package in the marketplace when you open/build it.

Only problem now is that the aircraft.cfg from FSX seems to be non-functional. I’ve got no engine thrust, and if I place myself in mid-air with slew mode, I’ll just hang there, with no control at all.

Also, for some bizarre reason, though the dev tools can read the aircraft.cfg while in the sim, they cannot edit it. Maybe that’s by design? But when you make tweaks, there’s definitely a “save and resync” menu option that just gives me an error about the action being impossible. Not sure what to do with that yet.

I might try building a new aircraft.cfg out of something like the Citation stock file, and see what I get.

Any news on getting legacy xml gauges to load?

XML gauges are not showing the images only the gauge frame. Does anyone know where i place the fsx cab file? Or why the images in the cab file fail to load. Here is the sdk showing the xml vcockpit still works.
gauge00=MODULENAME!GAUGENAME, 0,0,1024,768

Installed dotnet-sdk-3.1.401-win-x64
But i still get this message when i load the project.
the project file was unloaded.

I spent all evening trying to figure that out, but couldn’t really get it to work. I’ve placed the .cab files in the aircraft panel directory, though you should be able to put them in a package root “gauges” directory as well.

The gauges themselves seem to work, I was able to use one in the “SimpleGaugeAircraft” sample. But for some reason they don’t seem to render properly to the textures the mdl files want? I’m not at all familiar with how that works, so I don’t really have any clue on how to go further.

With the SDK you should be able to build and run it from powershell, just run dotnet run in the project directory.

I doubt VS versions before 2019 has support for .NET Core 3.

Where is the package root gauges directory?

I’m thinking next to the SimObjects directory.

It looks like the files in each package are mapped into an FSX like structure, so


would be similar to having the same in FSX:


Edit: Though, I also searches the panel directory, so it shouldn’t really make a difference since it should find it there if it exists.

FSX would look for gauges first in the panel then the gauges from the root directory.

We have been trying the pane location and the xml gauge will show the gauge frame but not the images.

I thought you found a gauges folder like FSX. It does not exist from my searches.

Sent you a private PM…

Sorry, it was conjecture on my part, I should have made that clear.

I’ve tried to use some of the new HTML gauges as well, but it won’t work either. So my thinking it’s the rendering that’s broken, rather than the gauge system. This is what I’m seeing:


I’ve been frustrated enough trying to figure out why, so I’m going to drop this for now and just enjoy flying around for a bit :smiley:

Hopefully not a stupid question, but how are you launching fspackagetool.exe? I can see it in the SDK\Tools\Bin folder, but clicking on it doesn’t do anything. It doesn’t appear to be in the DevMode manus, either.

Thanks either way!

I’m not @ChronocidalGuy guy :joy: but you open it via cmd or powershell. Then it’ll spit out the commands it takes.

Hah, you know, I haven’t even tried it, at least not on purpose. I’ve been doing everything through the DevMode menus in the sim, including building the packages.

The manuals were actually entirely wrong about one thing, I don’t think the “Build Project” button appeared how they said it would. I had to open the project, and then load the inspector, AND select the top layer of the project before it gave me the option to build anything.

Thanks! While I’m asking questions, would you mind giving a simple step-by-step about how you start a project from the Dev Mode menu? I tried there, too, but I’ve no idea what I’m doing wrong. Can’t find enough in the SDK to precisely indicates what goes there.

Tried starting fspackagingtool in cmd, but it just seems to specify requirements. Where is this entered?

A lot of questions, I know, but again, thanks either way. Would be nice to get one thing straight and build from there…


1 Like

Here’s an example in Powershell. Obviously the file path and folder name will be different, so you would have to change that.

./fspackagetool "D:/MSFS SDK/Samples/slinky-fsx-ports/SimpleAircraftProject.xml" -outputdir "F:/Games/Flight Simulator/Community"


Another update: Managed to get the wheels in the right placement and the swept wings working but still scratching my head at quite a few things. :crazy_face:


You drop the project xml on top of this tool and it will create 2 folders. Inside the new Packages folder there is your companyname-aircraft folder. Copy that to the Community folder.

1 Like

I sent you a private PM. Hope you can reply.

I have a question. Can we make the XAML.CS code updated so it also collects info for BMP images and creates a JSON.DDS file? Or will BMP just not work at all?

All my DMP and DDS textures are getting added tot he layer.json but the bmp textures are not creating json.dds files.

Also i had to update the slashes in the links to force only 1 slash in this direction. Here is the updated code that goes in 2 places.

.Replace(@"\ ", “/”)
NOTE this thread has no option for displaying code. So the first slash is actually 2 slashes.

thanks to klasbj for his software , and slinky for his patience : here is the result :