Funny CTD or program closing (repeated a few times) - When pressing the Seatbelt button in the FBW A320NX. Anyone else?

In the last days (since SU7 January Hotfix) I sometimes get a CTD when pressing the “Seat-belt sign” switch with the mouse, while in VR.
Does not occur all the time, but has happened to me at least three times in the last few days (the last time, it was a test flight where I repeatedly pushed the button several times, until MSFS crashed).
System and Software:

  • Alienware R12, no OC, i7-11700F, 32 Gb RAM, RTX3060Ti
  • VR Reverb G2
  • Windows 11, latest NVidia Driver (problem happened with both the latest GameReady and the latest Studio drivers)
  • MSFS Real time weather, AI air traffic, ATC without Azure voices (local text-to-speech)
  • Mods used: A320FBW (last development version), FS2Crew for A320NX, Flight Control Recorder, Bijan Seasons, GAIST ships, We Love VFR, Aerosoft Simple Traffic

Anyone else experienced something similar?

Just some extra information. I looked at Windows Reliability Monitor, and there is no record of any CTD associated to any of the events.
Also, when I restart MSFS it does not ask me whether I want to run it in “safe mode”.
Therefore, it looks like the MSFS program is closed by the user, not crashed.
Something like pressing Alt-F4, or clicking the “X” in the program window.
If have to investigate more, to see if clicking in VR the Seat-belt switch could also close the main program window…

The solution is pretty obvious…

1 Like

What is the obvious solution? (if I may ask) :wink:

Don’t press it. It’s hardly a game-breaker.

That is too easy a solution LOL (sure, no game-breaker)
But I will try to find some other workaround which still allows to use safely the seatbelt switch…
I was mostly interested to find out if somebody else had this issue…

Hi ,

I Had exactly same pb but with some buttons like STS on ecam 100% CTD or altitude button.

After investigating hours, in my case it was FSREALISTIC causing this we dont know why but all is hard coded and can conflict with msfs.

Thats the FBW team response: I also advise fsrealistic developper but no response.

The problem is that the sim is sensitive in general. Sometimes small timeing differences or order of API calls can cause the CTD. There are also so many different places where things can go wrong. In general applications talking to the sim are allways problematic. We have seen basically any of these apps as a „cause“ once. I‘m not even saying they have a bug but they do something that triggers the CTD in the sim. So no, sorry, I have no idea.

So in your case you have to remove all mods 3rd party and only test a32nx

Let us know if it works

1 Like

Also experienced two CTD’s with latest Dev version today. Both on the same route. First one just after leaving the SID and not clicking anything besides rotating the cockpit view and the second after dialing in the first flight level of the descent phase. FSRealistic running as well, but I never had issues with this. There was also a Windows update this morning. Maybe it’s weather this particular FBW-Dev version or the Win update, or a combination of everything :smiley: Hope it’ll sort itself out somehow.

1 Like

Hello I had exact same ctd when pushing alt button on descent and after many tests I affirm you its due to FSREALISTIC.

You can try just cold and dark on ground battery on try with FSREALISTIC to push STS button on ECAM, you will CTD.
Then, do the same test WITHOUT FSREALISTIC and all will be ok no ctd.

It happen Randomly

We have to report this bug to developer but no response to my mails.

Thanks for all the replies here, but I think I have solved the mistery…
As I wrote before, this does not look like the typical CTD:

  • Does not make a strange sound before closing
  • Does not show as a crash in Windows Reliability Report
  • I do not get the prompt to start MSFS in safe mode when booting again

My theory (not fully confirmed but highly plausible) is that when I move the VR mouse to the seatbelt switch (1 in the picture below,) the desktop mouse pointer ((which moves in parallel with the VR pointer) may be by coincidence just above the “X” (2 in the picture, aka “close window” button) in the top MSFS bar (I run MSFS in windowed mode, not in full screen). Therefore, when I press the mouse button, instead of setting the seat belt sign, it closes the MSFS window and terminates the program. This happens only from time to time, since the offset between the virtual (in cockpit) mouse pointer and the desktop mouse will be different depending on my sitting position and on my angle of view…

Final note: Asobo, please introduce an “Are you sure you want to quit MSFS?” prompt whenever the “X” in the top window bar or the Alt-F4 key is pressed.

1 Like

Hi Captains, we will check this issue due to the amount of reports coming in. In the meantime, we would suggest to try and turn off cabin ambiance effect and toilet flush effect which use the seat belt function. Updates to be followed.

1 Like

Hi , thanks for response. Plz also check pb with STS ecam button and sometimes also throttle pushing for take off cause ctd.

Hope you can resolve it.

Best regards

following here as I have the STS CTD problem too.

When I press that midflight (at 40+ fps). I hear the engine stutters than CTD. Restart, it does not ask about Safe/Continue too.

Except the AIG modelmatching for vatsim and fbwA320 exp mod, nothing else in my community folder.