G1000 on all Prop Planes Still Cuts off After 2 Minutes

Did 2 flights in the Caravan, GPS system screens went black. Never experienced this previously (have around 100 flights in the caravan in the sim since sim release).

After first time, came to this thread and monitored electrical numbers for the first hour of the next flight. Figured everything looked normal so stopped paying attention, and about 15 minutes later, boom, black screens.

I did setup an approach on the GPS prior to it blacking out (maybe 5 or so minutes prior), not sure if that had anything to do with it. Both flights were also started C&D.

Ola PlaneTadpole766,

I’ve fixed my issue with Garmin G1000 cutting out after a minute or two. I ended up updating the firmware on my Thrustmaster Throttle and Quadrant and it seems to have fixed the problem. I’ve now completed several flights successfully.

Hope this works for you.


1 Like

Had this happen to me again, in the SR22.
Except i was able to turn up the brightness, which turned the screen back on. If i even went halfway with brightness knob, screen would switch to black.
Very odd.

Hi Bartman766,

I’ll try updating the firmware. Thanks for the suggestion. Glad that it works for you.


Hi MarioH99,

I will try that and see how it works for me. Thanks for the tip.


Pretty sure I’ve found the fix for this.

I had the same problem: screens turning off a few minutes into the flight, only with G1000 aircraft, and only when the TCA Throttle Quadrant is connected.

Solution: edit the throttle mapping, and unset the “SET STARTER 1/2/3/4” engine instruments.

To do this:

  1. Open the control options page.
  2. Select the TCA Q-ENG input device
  • you might want to choose or create a custom profile only for these G1000 aircraft so that the following changes don’t adversely affect other aircraft
  1. Find the “SET STARTER” assignments
  2. Click on the white boxes marked “JOYSTICK BUTTON …”
  3. Click on “CLEAR CURRENT INPUT” to clear the assignment
  4. Click on “VALIDATE” to confirm you want no assignment

I did upgrade to the latest firmware first, but that didn’t fix it. I needed to clear the assignments as above.

Tested with Sim Update 10 on Windows 10, Thrustmaster TA320 flightstick and TCA Throttle Quadrant.


Hi StokedHurdle143,

Thanks for your input on this problem. I will try it. What’s interesting though, is that I’ve had this exact problem since almost the start of FS2020; from even before the TCA line of products came out. I had, and have the Honeycomb Alpha & the Bravo also. So, I wonder if your solution would also work on the Honeycombs. Thanks again for the input.


Hechos los cambios sugeridos por StokedHuurdle143 para solucionar los apagones del Cessna Garmin 1000, el resultado ha sido totalmente satisfactorio, después de haber dedicado muchas horas a solucionar este problema su solución es la que ha funcionado.
Muchas, muchas gracias.

1 Like

Hey StokedHurdle143, Not sure how you figured out how to resolve this issue but you’re a genius!! All is now working for me after many months of frustration!! Great Job!!!

1 Like

Hero!! I’ve been put off trying to fly these planes, because of the total failure (even gear retract didn’t work). Only workaround I found was to keep right-mouse click pressed and the electronics started working again - not useful.


Continuing the discussion from G1000 on all Prop Planes Still Cuts off After 2 Minutes:

Had a similar problem with both beechcraft planes. On a replay in the Nice France landing challenge sometimes the engine data would not show up on the PFD. Found that multiple clicks on the Avionics panel switch would repopulate the engine data on the PFD. Mind you that the Avionics switch does not toggle on the panel (but it wobbles a very little bit) and the MFD does not turn on with that switch like it should (but once in a while it’ll flicker while performing the multiple click fix). Many of the other switches in these aircraft, lights in particular, do not visibly toggle or function. I am running on a PC with win 10.

Hi there
Mine cut out after 2 minutes on everything then I realised what the problem is. When you start the motor I would leave it in that position on my honeycomb rather than then switching to engine both - which is right next to it please see the picture - now works perfectly.


Hi Keyser1975,

I always have my Honeycomb set to “Both”, and the screens on the Garmin 1000 still go blank after a couple of minutes. Maybe if I recycle the switch and return it back to “Both”, it will solve my problem. If it does, I will report back. Thanks.


**rillant worked for me cheers

1 Like

Thank you! It solved my problem :+1: