G1000Nxi Pan button turns yellow when pressed but doesn't pan, only zooms

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Have you disabled/removed all your mods and add-ons?

yes

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

as per title

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

No steps to reproduce it, but I tried it both in lock mode and in legacy mode. There are actually different problems depending on which one you’re using.

Lock Interaction Mode (Options > General Options > Accessibility > Cockpit Interaction System = “Lock”)
It doesn’t work at all (see video below).

Legacy Interaction Mode (Options > General Options > Accessibility > Cockpit Interaction System = “Legacy”)
It does pan, but the cursor seems to move painfully slow. See the attached video, below.

Provide extra information to complete the original description of the issue:

For legacy interaction mode, I am not proficient enough in the G1000 to know if there’s a setting for the cursor speed somewhere. Maybe the explanation is that it got changed? Not sure.

If relevant, provide additional screenshots/video:

Lock interaction mode (doesn’t work at all):

Legacy interaction mode (really slow):

Tks, I dont get how you are making it pan. My ‘Range/Pan’ turns yellow, then can be "wobbled’ side to side etc. presumably to pan, but I cant see anything happening. Your video has the screen moving, but your button is not yellow and I cant see the cursor.

1 Like

This might be partly a case of Lock vs. Legacy control bindings.

1 Like

I’ll try this in lock mode tomorrow.

Thank you for that! More info added to my post.

Fixed in SU12: Release Notes - Sim Update 12 [1.31.22.0] Available Now