G2 jumpy display

It’s actually called “Setup Room Boundary”, unless you’re talking about something totally different from what I did. Because I’m stationary in a hospital bed, it consisted of a single step which was "Point your headset at your computer and hit “Center”, which I did.

I guess we’ll see if that did anything, whatever it may have done, it was instantaneous. I did make sure the external facing cameras were not covered by my hands when I did it, though, even though there were no instructions or anything to that effect that suggested doing that.

I appreciate your help, I guess I’m just going to have to try a few flights to see if it’s still doing that moving/jumping around thing.

In case you have you monitor in direct view to the headset and especially if this is a large one, you might want to turn it off too. The G2 cameras might be picking the moving screen content as a moving headset exemplifying any subtle movement.

Otherwise there is another subtle movement you can perceive sometimes but honestly only with Light House chirurgical precision tracking (light and days between the Index and the G2 - I own both - regardless of any progress inside-out tracking technical progresses). This subtle movement is the one due to your blood pressure in your bottom when seated making your body slightly jittering back and forth at the same rate as your cardiac pulse rate :slight_smile:

@CptLucky8, you just opened a can of worms, without even trying to.

First, let’s start on topic. I reset my environment parameters, AND I followed your advice about turning off the monitor, and it seems like the jumpiness has improved, but it’s going to take more testing to say that with certainty.

Now, to the can of worms.

When you suggested turning off my monitor because it has the same content as the headset, I did.

And what happened was that my system responded by moving that window over to my secondary display. Still visible to the headset, but not as large, and not in the central field of view, but we still haven’t gotten to the worms.

Here they are:
That secondary display is not attached to my GPU. Rather, it’s attached to the onboard graphics, so it got me thinking that by doing that, it may free up some additional resources for the GPU and HMD, as the HMD was now the ONLY thing getting it’s graphics from the GPU. But oddly enough, that didn’t happen. So I got to wondering why freeing up those GPU resources would NOT increase my HMD performance, when…

On a totally unrelated thing, I was downloading an update to my PA44, and wanted to measure the bandwidth, so I put the MSFS window on the secondary display that, again, is NOT connected to the GPU. What I noted, almost by accident, was despite the fact that my GPU was no longer driving that window, it was still having high usage.

So, here’s my conundrum. How can the sim running on a monitor NOT connected to my GPU cause the GPUs resources to be high? Is the GPU somehow still driving the computations, but then pushing that info over to the integrated graphics to be displayed on the second monitor? That’s the ONLY thing that explains the high usage of the GPU, but at the same time makes no sense because the GPU was removed from the equation.

Is that even possible? I mean it has to be, because there’s no other explanation.

Thoughts?

OK. So what that’s saying is exactly what I was thinking, that the GPU is in fact doing the work, even though the integrated graphics is presenting the result to the display.

But… What if I don’t want it to? What if I want to give my HMD 100% of the GPUs attention, even if it means that the MSFS window on my secondary display looks like puppy excrement? Wouldn’t that just give my VR session more GPU cycles to use all to itself, thereby increasing the power going to what I’m seeing in my matrix hood?

I wouldn’t even mind turning off ALL my flat panel displays, the only thing I use them for is for Afterburner as a framerate counter (and I’m still not convinced it’s counting what I’m seeing in the HMD), and to access Navigraph to get to my approach plates, which I should be doing on my tablet anyway, and soon enough I predict it will be available inside of VR anyway. As for an fps counter, I’m past the trying to chase fps for the sake of bragging rights, I primarily want it as a tool to gauge what a change I might make (say from changing grass from off to medium) has on the overall frame rate. It’s easy to say, well it’s ONLY 1 fps, except when we’re potentially dealing with 10 different changes all of which carry a performance of “ONLY 1 fps”, that adds up after enough of them, especially if we started at say, 32 fps. (A number I just plucked out of my butt.)

I would prefer to not have the binocular FS2020 image displayed anywhere, but I’ve found trying to do that results in losing control of your mouse making it a non-starter.

I’ve tried in the past looking for options to using the 2 GPUs I have as well (the NVidia and the one embedded in the 9700K which does nothing otherwise), but I’ve not found most answers. You can still assign a program to a GPU ( see the picture here: My 2070 SUPER 4K settings and suggestions - episode 2 ) but I’m not sure it is actually working as intended if the discrete GPU is taking over. I’ve not given more thoughts for a while but I’ll welcome any solution too!

Same here with the jittery tracking on the G2. Problem is, this doesn’t happen in cliff house, steam house, nor Google Earth VR…so it’s not the headset, it’s MSFS.

Might be the relation between controllers and headset. I assume you use the controllers in the other apps. Do you have them on and sitting somewhere in sight while in FS?

Just currious because I don’t have this issue.

Actually I thought the same thing…tried MSFS with the controllers on and in sight of the cameras…same jitter.

Also tried Google Earth VR, with them off, and it was still smooth while looking around.

Also, what I don’t get, is that the goggles window looks so smooth, but in the headset, it’s stuttery. If I could only get the displayed goggles window to go to the headset, seems like it would be great.

I try and keep bright lights away from my forward vision and as I’m sat infront of my PC I make the MSFS window as small as I can so there’s less movement. Shame we even have these issues but there you go.

Does the stutters change when you drastically reduce render scaling and graphic settings? Or is it all the time?

That’s because you’re getting 90fps in the clif house AND every one of those 90 frames knows where your head is at that time.

If you drop frames then it will stutter, if you add reprojection it’s guessing where your head is so it will stutter. I’ve got it pretty smooth now but that’s because I’ve overclocked everything :slight_smile: with reprojection and to try and render 45fps in VR which is keeping everything smooth in my G2.

Yeah, I’m coming around to that bottom line too…dial it all back till you can get 45 rendered, then only x1 repro.

Running a 10900k at 5.0 and a mild factory OC’d 3090. Cannot get visuals, readable displays, and smooth all at the same time.

1 Like

In steam VR, Google Earth, looking at frame time display, 100% res, frame times are about 5 ms, or 200 FPS even with all those 3D buildings and trees textured polygons over a full 3D area…so I know the card can render like crazy.

Hard to believe the flight computations part drops that by a factor >4x. I guess I’ll have to wait for CPUs with single core speeds of 15 GHz for it to look good…hope I live that long.

1 Like

Yeah, unfortunately, with the same config, to have it smooth, I run the OXR at 65 and 100% render scale in game… Waiting for optimization. It’s ok, but it could be better

2 Likes

I have a 9900K @ 4.7Ghz locked all cores and 2080Ti (OC +150Mhz core, +500Mhz RAM) :slight_smile: OXR 65% runtime preview enabled, repro on always and in MSFS render scaling on 70% buildings and terrain on 100% rest on medium/enabled, all traffic / ai off.

Yes the reprojection has artifacts and yes clarity isn’t perfect but it’s 45fps (therefore a solid 90fps in the headset) pretty much everywhere in any weather. Even if I change OXR to 70% I notice it as I’m super sensitive to stutter so this is perfect for me, it really does feel like the cliff house so that absolutely is possible and the headset doesn’t jump around at all - the tracking is very smooth and accurate.

With a 3090 I would have thought you could have had my settings, keep OXR at 65% and as @AIRBORNE4795 has said put the MSFS TAA render scaling to 100% that should be perfect, plus a few graphical settings on high as well like textures and clouds.

I think the point is it’s a balance even on a 3090 but if you are careful not to stretch things too much you can have a blinding experience in VR and for me this is a joy to put on the headset.

1 Like

Don’t you just need 30 FPS (not 45 FPS) to reproject to 90 FPS?

I like is at 45fps. It just seems smoother because there are less reprojected frames and there is a lot more leeway for handling more scenery / weather / plane types. It just allows me to fly without thinking about settings.

I had jittery head movements in the G2 and I solved it by turning off the Windows Mixed Reality Portal screen preview - just press the “Pause” button at the bottom of the WMR Portal window so that it stops reprojecting the image from the headset.

2 Likes