G2, WMR and Windowed Foreflight on ApowerMirror

Greetings pilots,

I’ve spent the last six months or so trying to migrate my VR environment from X-plane 11 using an Oculus 2 to MSFS2020 on an HP G2. It’s been a very frustrating experience since the G2 didn’t work with my very expensive 3090Ti. I’m at the edge of the jaded abyss.

However, I kept at it and persevered to the point where I have only one item left on my checklist.

ApowerMirror is the s/w that I use to display my iPad on the PC. It’s an application like any other app and really doesn’t have any special magic to display the iPad. For the Q2 I used the Oculus dash to bring in and pin the window to use in either X-Plane or MSFS2020. Either way it worked well.

The problem I’m having with WMR is it doesn’t display the application. I get it up and running but it either just shows a logo on a blue screen, or shows a black/grey screen. Either way I cannot for the sake of my sanity get this app to show inside the sim.

This is the final piece of my puzzle and means a lot to me to get Foreflight working inside my sim. I did try Navigraph but don’t like the lack of VFR maps and a few other features. I don’t like FSKneeboard for the same reasons.

If anybody has a solution to this that might help, we’d be besties forever.

i appreciate any feedback anybody has.


The only way I got foreflight to work in WMR is to use Microsoft Teams to set up a meeting between my desktop and my iPad. Then start Teams inside the WMR house and join the meeting on both devices. Once established, then share the iPad screen with Foreflight on it. Be sure you have the MSFS data being sent to Foreflight as well.

Go back into WMR and lock the meeting shared iPad screen to your view. Then start MSFS and go into VR. Once there you should see the Foreflight screen in the cockpit. You can resize that window to fit your taste.

I also found that I needed to login the iPad side of the meeting as a guest since you will probably have logged in already on your desktop. So far this is the only way I got Forelight in WMR. It’s a lot of steps so I don’t use it all the time, but it does work.

How clever! I’ll have to give this a try. Durning lunch I tried another way. I set up a small monitor I have to 1020x768 portrait. The iPad fills the screen and I share that desktop. I’m surprised that it worked. The latency isn’t issue so that really helped. So I was able to bring in that desktop and use Foreflight. How is the screen control with your method? Is it easy to resize?

I’m having some problems with WMR and Microsoft Windows. (Imagine that) My system freaks out if I have multiple monitors and try to use the desktop functionality in WMR. It actually makes the second monitor the primary monitor and causes the system to ■■■■ the bed and roll all around in it.

Anyway, I’m trying the Teams solution and was wondering about latency. Do you have any latency issues with using Foreflight?

That blanked out word is See-Are-A-P. Not the S word. Touchy system.

This doesn’t work for me either. It removes the accessibility functionality during the screen share process. Now I can’t navigate. How do you navigate using this Teams method?

WMR should be able to show a single app in VR, although the steps are a bit fiddly (and I couldn’t find a decent video of how to do it as yet). Here’s how I bring in Pilot2ATC etc into WMR VR and MSFS (so I haven’t tried it with Foreflight, but hopefully the same, although some 32-bit apps do complain).

  1. In WMR Home (where you start when you put the headset on), press the keyboard :window: Windows key to bring up the blue square WMR menu.

  2. In that menu, find the entry ‘Classic Apps’ (you might need to use the arrows on the right to ‘page down’ in the menu). This should then be all the folders/shortcuts of your regular Windows apps. With that icon hold the mouse or VR controller pointer over it, and you get a ‘Pin’ option, so it appears in the main WMR menu squares (saves having to dig down into ‘Class Apps’ each time).

(2b. If you can’t find a shortcut to the app you want, use Windows Explorer beforehand and put a shortcut in %programdata%\Microsoft\Windows\Start Menu\Programs\ ).

  1. With the app now open in WMR Home, resize it and use the top right ‘Follow Me’ pin icon. The app will now sort of move as if it was a table in front of you.

  2. Start up MSFS (maybe from the Desktop widget in WMR, also found on that menu). Notice that the ‘Pinned’ follow me app should be still around and overlayed in your VR view.

It can be a bit clunky with mouse pointer focus, so you might need to alt-tab and all sorts of wrestling with that side of things, but it’s not too bad.

Here’s Notepad.exe from ‘Classic Apps’ and the ‘Pinned’ follow me icon highlighted.

EDIT: This might not help with Foreflight as an iPad app via Teams etc, but wanted to at least show how Teams could be used with a pin. :expressionless:

Yes this is how the teams meeting works as well. Its a pinned app and you can resize and move as needed. I found that sometimes the teams window moves around the cockpit when you look around, but usually locking it in place seems to work. All in all this is not the easiest to set up and use, I find the Navigraph charts better for what I need. If they create a VFR Sectional to Navigraph, then you probably won’t need the Foreflight window.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.