Game freeze when online functionality is switched on

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. - no

Are you using Developer Mode or made changes in it? - no

Brief description of the issue:
Game freezes when online functionality (OF) is switched on.

Provide Screenshot(s)/video(s) of the issue encountered: -

Detail steps to reproduce the issue encountered:
When OF is on, the flight won’t even load.
When OF is switched off, the flight will load.
If OF is switched on in flight, the game will freeze.

PC specs for those who want to assist (if not entered in your profile) -

Build Version # when you first started experiencing this issue: current latest version of the game

Are you on the Steam or Microsoft Store version?
Microsoft Store.

Did you submit this to Zendesk? If so, what is your ticket #? -

tried already a re-login ?

Yes, doesn’t help.

hmm… I mixed it with the connection lost issue.

But I thought I also read somewhere somewhat about what you describe… may be it was disabling bing / photogra…

That doesn’t work either. As soon as I switch on the online functionality, the game freezes.

Also I want to fly with photogrammetry on, else I could as well play FSX.

1 Like

of course :slight_smile: … but somewhere we have to start to find what the reason is…

Does the game ‘freeze’ , e.g. “not responding” in taskmanager, or crash ? And exact in the moment where you enable online ?

1 Like

The game does freeze, about a couple of seconds after I switch the option on. One thing I noticed as well is that my multiplayer is not available/greyed out.

hmmm… not remember and quickly not find an existing topic about.

But, may be it is still realy a login issue. But if you already re-login in xbox app… hmmm…

Still trying here. I am experiencing XBox connectivity issues aswell. I just wanted to fly man, and now on my saturday evening I’m stuck with this.

oh… that can explain issues in msfs… but who knows.

Which kind of issues ?

yes… I understand that of course , and I would be also not happy if that happens me. But we can here nothing do as discuss possible workaround / solutions.

In each case I recommend to create a ZenDesk Ticket, which is the official issue-report. Will not help to fix the issue quickly, but its documented.

I had problems with online functionality months ago. My solution was:

  1. Shut down the sim.
  2. Log out from XBox.
  3. Restart your PC (RESTART, not shutdown!)
  4. Logon in XBox.
  5. Start the sim (and nothing else!).
  6. Go to online functionality…

Hope this helps you too.

I’m having the same issue with the MS Store version. Sadly, logging out of the the store didn’t make a difference.

The only way I can see photo imagery is to load into a flight with online functionality off, then turn the setting on once the flight is loaded. Unfortunately, this only lasts a couple minutes before the whole dumb thing locks up completely.

I have the same issue.
Allready reinstalled W10 and MSFS, but still the same.
Zendesk has also no solution for our problem.

Interesting thing is that when I load my CRJ700 from Aerosoft (Direct buy from Aerosoft) everthing works fine!


1 Like

So I’ve narrowed the problem down to Teredo and therefore any Xbox-live connection getting blocked on my PC. I’ve found out that my router was the culprit, and set it to allow a Teredo-connection. Then everything worked again, but unfortunately only for two days. Just after World Update 6 the very same problem appeared again. I checked my router, and the Teredo-connection is still allowed. But the game still freezes with online functionality, and occassionally, but for some mysterious reason not all the time, my PC tells me that Teredo is still blocked. At this point I’m really desperate and frustrated, and my only option seems to reinstall my entire C-harddrive, or get a new router which for me means moving in a new flat.

Weirdly the nature of my problem is the exact same! Aerosoft CRJ and PMDG DC-6 works fine! But everything else, not.

Its still the same, even after WU Germany, Austria and Switzerland.
Hoping for next BUG-Update!

have in mind that the games developers can not fix issues caused from a installed mod

Exactly the same for me. Haven’t tried the DC6 but with the CRJ everything runs normal.

1 Like

Same here. DC-6 works fine, every other aircraft causes it to lock up. Empty community folder and it still locks up. This is on Asobo, not third party products.

1 Like