Game freezes while loading a flight

It’s the same at RAF Benson. stuck on loading. Thanks anyway.

Exactly, I paid to be able to fly this sim not work on it all the time

2 Likes

Experience this issue as well, sometimes it is livery dependant, some liveries force 2 blackscreens while loading and then the loading-screen is freezed in VR.
Since the last MSFS crash (landing challenge Duesseldorf had orcan winds and the whole computer crashed) it refuses to load this landing challenge and always freeze the loading screen.

I started to get this issue after Sim Update 7. Does anyone know how to fix it?
I can’t start a single flight.
I reinstall the game and delete everything from the community folder, but it didn’t work. Thanks

I have this issue

what do you mean by new start?

what should the status of the rolling cashe be?

that sounds right im in the south east and just hangs while loading a flight ,have to go to task manager to end it.

Good Day. PC has Ryzen 7 8 core. Graphic Radeon RX 5700 XT MSFS 2020
has 458gb ssd sole use. I have uninstalled and reinstalled the game
twice. The community folder is empty. On loading and then selecting a
flight eg training. select FLY, the correct screen comes up but the
blue bar only gets to 75% across and then freezes. The only way too get
out of it is ctl alt del. Also the opening screen asks whether I want
to start in Normal or safe mode which is nonsensical considering this is
a fresh install. Whats the solution??? Regards Grahame Cross.

From zendesk suggestions https://flightsimulator.zendesk.com/hc/en-us/articles/4406039624338-All-versions-Loading-issues-Checklist.

https://flightsimulator.zendesk.com/hc/en-us/articles/4406047820690-All-versions-Sim-freezes-or-crashes-before-loading-fully.

RESTORE THE SIM TO ITS VANILLA STATE Did all this twice. Tried using a different gamer tag

Second email to zendesk. Good Day again. Well having done all that was suggested plus more. The more included upgrading to Win 11, uninstalling and reinstalling the whole thing twice and the programme still refuses to go past the FLY instruction in all the various activities. To use the word frustrating is an under statement. All I want is to use is the programme that I paid for.

3 Likes

I have the same problem and did the same fix inquiries. Two reinstall and no community folder. How did you fix. All I want is what I paid for. About ready to start a complaint with the consumer protection agency.

1 Like

Здрайствуйте, Вы решили проблему с запуском, у меня такая же история

may, also if it is already known, because lots of search results points to it, I would ask whether you have/had the google-maps-addon installed ?

If so, remove the C:\Windows\System32\drivers\etc\hosts file :

@CitrineWheel392 forum language is english

1 Like

thanks the game is up

1 Like

It’s not just starting a flight when it happens.

I’ve just come back to the sim after months away because of issues with installation, to finally have a clean install. But when I run the game, it checks for updates, then begins to load the sim, getting about half way along the blue loading line and then hangs indefinitely with my task manager telling me it’s not responding, even though it’s using high power and continuing to alter memory usage.

Clearly Asobo have messed up, again.

I am getting so incredibly tired of how shoddy this sim is getting. It’s all fluff and no joy. Hours, days and even weeks troubleshooting, with no end of sight on solving the problems just getting the game to load, once! All I seem to be doing is leaving posts about how it isn’t working.

And my system is very good. 8700k, 32GB RAM, 2TB SSD, Nvidia 3080Ti, Windows 11.

It’s not even a joke anymore, it’s disgusting.

I am so disappointed in In the flight simulator. I have the exact same problem, and its 22/08/2022! They got to fix it!

I don’t usually have problems with the simulator. If so I have always tried to reinstall it and it had always worked. But now I’ve tries that 3 times. 2 times on Microsoft and 1 on steam. Yes I made a dumb choice to buy it on both. Well to the problem. I can log in to the game very good like I used to. But when I try to spawn a plane in a random airport it freezes when I am at around 80% of loading. I know that it takes around 2 min to get in, but I’ve waited 20 minutes and it still didnt load in. I went into the task manager and it said Microsoft Flight Simulator Not Responding. Someone said that if I had installed Google maps version I should remove some text from the Hosts file in File Explorer, well it didn’t work. Help!

Just this problem I am facing too, when I try to load ESSA as departure Airport. In my case it helps, when I choose another airport. Try it out, maybe it is a solution for you.

If the solutions above dont work, you could try 2 things. They have worked perfectly for me. 1. Roll back Windows updates from this month. 2. If using Nvidia and upgraded to driver 516.94 released on 9 Aug, switch back to previous version.
Thanks

I’ve found the solution if you have downloaded Google maps instead of bing. If so do this:
Remove the Hosts file altogether.
Restart PC.
Window’s will make a new one.

Large complex airliners do take 10 or more minutes to load for the first time.

If the issue still exists, start with this troubleshooter: https://flightsimulator.zendesk.com/hc/en-us/articles/4406039624338-All-versions-Loading-issues-Checklist

Same problem here, but only when live weather is set. Try loading a flight with clear skies, then from the weather menu once loaded select the live weather switch on. This work-around works for me.