Game randomly crashes mid flight

Thanks for the heads up. I installed 77 just after the SU8 update. I wonder if that’s why I’m getting constant CTD’s. I will test that tomorrow. Thanks

Have the same problem. Tried to start in safe mode. Still happens. Could someone try this bush trip (Austria Tyrol High Mountains) to see if they get a CTD. Its a few minutes before you reach your first destination on the first leg. Mine keep CTD a the same point.

1 Like

What ever they changed. It fixed it, I did a 3 hour flight with addons and didnt get any CTDs (Addons: WT G3000 | WT G3000 RD | TBM930 Improvements).

I had 2 ctds today when flying Captain Sim 777-300ER. Don’t know if that’s the problem I flew a 6 hour flight yesterday with the same plane and had one ctd. Now 2 in a row.

It’s Asobo as on the ms version for Xbox and pc I get constant crashes and black screens after the most recent update.

During short flights (<20min) I’ve seen 2 CTD’s mid flight today… one with Pilatus over EHEH flying, the other one Longitude over Toronto, CTD in pause mode.

Mine is continually crashing too at the moment, only started very recently. I reverted my Nvidia Drivers back to December, but the issue remained. About 20mins or so into a flight just straight to the desktop, not always, but quite consistently. Inclusive of both the FBW A32NX and the Aerosoft CRJ - so I doubt it’s a plane.

The only thing I have changed is installing Ambitious Toolbar Pushback with the pre-planning. Going to remove it now and see if the issue persists, maybe it’s conflicting with something. Otherwise it must be a SU8 issue.

I can confirm that my sim is no longer crashing anymore - having uninstalled the Ambitious Pilots Toolbar Pushback.

I imagine it’s a conflict with this add-on and some sims. Give it a try.

I had repeated CTDs after just a few minutes in game, no addons at all.

Try these things, they seemed to stop the ingame CTDs for me, SU8:

  1. Windows 10 - Turn off GPU scheduling in Windows 10 (google the term if you don’t know what that is)
  2. Set a GPU delay in registry editor (see the link)
    GPU drivers crash with long computations (TDR crash) | Substance 3D Painter

After doing these 2 things the CTDs seem to have stopped for now.

Before that updating the nvidia drivers/ and using safe mode had no effect on crashes, it still CTDed. Also check the windows event log after the CTD, I always had the same specific error code related to GPU in general.
Hope it helps.

I assume all on forum know HAGS, because it is for some users a main source of trouble…

TDR points often to some other issues with the GPU… A generally fps limit, as often recommended, may help ( and show you a possible existing overheating aspect ).

1 Like

This is seriously extreamly frustrating. Just going directly to desktop after buzz sound without anything said.

many reason possible… sound-drivers… anti-vir… rolling-cache… mods… login-issues… corrupt cloud-files, system issue… you must be bit more specific what,when,… happens.

Eg. Where is the state of the blue-line ? have you a different error number as e.g. here Game randomly crashes mid flight - #25 by ArcanePython931 reported ? more infos which can help ? what you tried… when it starts… etc.

And in case you realy meant you can no longer start MSFS, then there are more specific topics about. This one is for “mid flight”.

There is a big topic on this.
Make sure you also vote here:

Exact same problem on this bush trip as well for me. Crashes right after the second last waypoint changes to the last one on the first leg (POI4 to LOWL). Three times in a row, tried normal and safe mode.

I get exactly the same, came to this thread looking for an answer to my problem.
It happens everytime exactly in this position:

It happened four times on me, both in normal and safe mode.
I normally have no CTDs at all.

can please open the windows event viewer and check whether the error message contains “grammar…” ?

If so, then have a look at here:

No, my errors were in the vcruntime140.dll module.
But I really know nothing about this stuff. I’m enclosing the screenshots for the 4 error instances I’ve had if it helps.
Sorry my OS is in italian :pizza:.




1 Like

then may be a mod / add-on which cause that…

I will retry LOWL and the location in your picture too :slight_smile:

EDIT: no issues here

I just bought the Bilund (Denmark) airport and tried 4 ILS approaches on different runways that all ended in a CTD after a short period of stutter which started around touch down. I have CTDs from every now and then but not to this extent. I’m on Xbox.

Sadly it’s not a third party addon issue. It also happens with an empty community folder.

I thought it could be connected to the specifics of the Bush Trip or to the Garmin Nxi, so I went back in free flight with the default Cessna, and got just the same CTD in the same location. Both with the G1000 Cessna and with the steam gauges one.

Look at the two tracks:

The CTDs happened at exactly the same spot. I have no CTDs at all in other locations.

Could it be connected to the autopilot maybe? All my flights were conducted with the AP on in APR mode to be sure to get to the same exact spot at 2500ft. Will try hand flying it.

BTW it also happens without Littlenavmap and I’m on PC.