Game won't start, stuck at splash screen

I have a Steam version of MSFS. I haven’t played since around UPD8. Today, i wanted to run it to download updates that were released since, but i got stuck on the splash screen. I checked the resource manager, and the process does absolutely nothing, no disk activity. There’s some network traffic, but at single digit bytes per second speed, so it’s definitely not downloading anything.
So i went through the usual. Deleted the rolling cache, deleted everything from community folder. Didn’t help. I did the Steam verification, which ran to 100% without issue, but after it was finished, i found out, that it completely deleted the 100GB+ of the game data that was there before the verification. Interesting verification proces…
So, since the game was gone anyway, i uninstalled the rest of it, and reinstalled from scratch.
Of course, Steam only downloads the 1GB launcher, and the rest of the process goes through the game executable itself (which is a demented way of doing things, and i really hate this).
After it downloaded the launcher, i ran it, and yes, you guessed it, it’s STILL stuck at the splash screen.
At this point, i don’t know what else to do. I got relatively new computer, i5 12600K, 32GB RAM, GTX1660 (to be replaced with RTX when the prices go a little more lower), latest Win10 version installed from scratch this March.
Soo - WTH? Tips are welcome. I’d like to fly again.

The usual would be logging out of all accounts manually, restarting your PC and manually logging back in again. Also check Xbox and Steam for any updates, especially digital ownership.

Check your hosts file in C:\Windows\System32\drivers\etc for entries. I tried the map enhancement mod once, and it left entries in there. You can delete them safely, or create an new empty hosts file if you want to keep any entries you have in there in a backup copy.

Thanks, i checked the ETC folder files, but there’s nothing out of the ordinary. There’s only the default commented stuff in there.

where exactly is hang ? Did you see already the blue-bar , around which prozent % ?

Otherwise a login-issue is common, think it is what @DensestSnail693 meant. So, did you tried already xbox relogin ( restart in middle ) ?

And may be… have you already tried the -FastLaunch option ?


yep, may be waits for more votes: Steam - Verify Integrity of Game Files Deletes All Content

First thing always…check sever status!

Xbox Status | Xbox Support


No, no blue bar. The game gets to the first splash screen, right after the logos, with the planes in the background. There’s the “loading” animated circle in the bottom right, and that’s where it stays. I initially thought that the issue was caused by some addons that stopped being compatible during the time i haven’t played the game, but first i deleted content of Community folder to be sure, then i ran the Steam verification process, which deleted the rest of the game (thanks for the link, voted). After that, i tried reinstall from scratch, but it took me back right where i started. To the first post-logo splash screen with animated “loading” circle in the bottom right corner, and no further.
The game isn’t downloading anything, there’s no disc activity. It’s just stuck there.
What’s Xbox relogin? I’m on PC…

there is a xbox app on your windows, here you can try to relogin.

The xbox-services which @ccrbc mentioned are in meanwhile back to green, is may be your issue gone in meanwhile too ?

Also a note about new install or steam-verify: dont forget that these process often not clean the files within the %AppData%\Micr.Flight… folder. If there is a problem here, users should after un-installing the game then manually clean that folder. Also the stored cloud-data exists futuremore. But I think issues here are more if you reach the “blue bar”, but who knows.

1 Like

Wow, i had absolutely no clue whatsoever that windows has an xbox app. I either never used it, or if i did, i didn’t know that that’s what it is.
Afaik the only stuff that was running while i was flying around was Steam, MSFS itself, and stuff like simtoolkit/littlenavmap etc… Thanks, for your input, i’m gonna check out the appdata MSFS folder as well.

1 Like

Ok, looks like progress, i’m at the accessibility settings, so something definitely changed without my input.
It’s downloading. Only at 20Mbit, as usual, but i hope that with a bit of VPN jumping i’m gonna find a better way. ■■■■■■ if i never clicked on the ■■■■ VERIFICATION thing, i could have skipped this 2day redownload martyrium…
Looks like the issue was truly with the invisible background XB login process after all.