Gaming services updating causes CTD

Please tag your post with #pc and/or #xbox.#PC

Are you on Steam or Microsoft Store version?Microsoft store

Are you using Developer Mode or made changes in it?No

Brief description of the issue:While flying normally without any Issue, all the sudden I have CTD and at same moment I receive a Notice “Gaming Services has been updated”. I want to stress that those are the only CTD I hade since I purchased MSFS2020 as soon as it was released

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

I have exactly the same issue! In my system log, I can see the update installing and I get the CTD at exactly the same time!

I am using gaming mode BTW, so updates should actually be blocked while using MSFS!

Be sure that MS store apps are up dated.

I finally localized the problem. It is the Windows Store. It will update all apps constantly even if they are up to date and auto update is disabled in the store. This includes the Gaming Services app. As soon as an update is triggered for this, there is a CTD. I have tried everything to fix it as listed in a “Windows Club” article, called “Microsoft Store keeps updating the same apps every day in Windows 11/10”

Nothing worked for me, but this workaround has cause no CTD in the last 3 flights:

  • Start Windows Store every time before you start MSFS.
  • Go to Library and update all apps
  • Close Windows Store

Hope this helps!

Hate to resurrect a year old thread but it bears relevance. Sometimes I get a CTD on load up or if I leave it on the menu screen for a bit, come back and select world map, a CTD occurs. The event viewer points to ntdll.dll which is the equivalent of saying “There’s a good chance the sun will rise in the morning.”

Anywho, yesterday, same thing happened and I began to investigate further. I only really sim at weekends when I’m not working which is usually when this problem occurs. In the past I’ve overcome it by restarting the PC (bring back proper shutdowns!!). I then went in the Windows store and there was an abundance of apps needing to be updated, 2 of which were gaming services and the Xbox app. Looking into the logs and cross matching the dates showed the CTD happened either because these apps weren’t up to date or that an update suddenly started loading up.

I updated the apps and Bob’s you’re uncle, no CTD and I was flying pretty much most of the day yesterday. This then ties in imho with the restart as that’s probably when updated apps finish doing their thing. It could also explain the, “I don’t get any problems with other games” statement by users as more often than not, they aren’t being run via the Xbox/Store app.

Anybody experiencing random CTDs might benefit from this.