Garmin Avionics are missing RNAV approaches

IFR flight is rather broken in the current state of MSFS. We are missing a lot of Instrument features in the Garmin FMS. VNAV, I believe, is in the works and is a known issue but where are my WAAS approaches? They are not even listed in the Database in the FMS. Are there plans to add them?

Its’ been like this since release. Approaches/departures at smaller airports seem to be missing, larger airports are using partially complete data with missing transitions etc. Direct to in flight plans works, but you can’t program direct tos without having a start and end airport in the FP. Direct to on approaches that do exist seems inop. LNAV G/S in rnav is present for some airports. Happy flying lol.

3 Likes

“Funnily” I just noticed that KSBP is including RNAV approaches, but missing the ILS approach in database. That was in-flight. In the end I decided for a visual approach as the safest option :unamused:

Last night I was landing the TBM 930 at KLAX with RNAV. I had the approach I wanted selected and I entered the approach at slightly below the normal entry point (I was at 2700 ft., flight plan was 3000). I never could get the approach mode to control my altitude and ALT, VS, FLC, and VNV were all turned off. I crossed through the glideslope a few times and the plane still didn’t want to enter the glideslope as was set in the FMS. Autopilot was actually fighting me and trying to get me to pitch up when I was already above the glideslope and trying to descend to meet it. I tried toggling AP and Approach mode on and off and that didn’t fix it. Neither did throttling up or down, like you would in FLC mode.

FYI I am new to flight simming, but I did watch a tutorial on RNAV in FS2020, and I was actually able to get ILS to work in the TBM on my previous flight.

Sorry I am also new to flightsiming can anybody enlighten me what does “VNV” and “FLC” actually stand for? I am trying to figure out how to fly IFR plan with the TBM 930 but I don’t know / missing many steps :frowning: … Also is it possible to set particular throttle (on the AP) on this aircraft as the AI pilot always flies it 100%? Sorry for newbie questions :frowning:

1 Like

VNAV is Vertical Navigation, whereas LNAV is Lateral Navigation.

LNAV is azimuth navigation and is already in the airplane. It is actived by pressing NAV while having the FMS selected as the navigation source on the CDI.

VNAV controls your climbs/descents in relation to aircraft performance data and any altitude constraints present, so you can safely navigate the airspace or be at your planned altitude at the planned time/position. This does not work currently in the simulator.

FLC means Flight Level Change and commands a maximum rate climb/descent at the current airspeed. You basically set a certain forward speed for the autopilot to hold with the current engine power setting.

The TBM 930 does not have an autothrottle feature. The TBM 940 does. The correct throttle setting would not only depend on the speed you want to fly at, but also environmental conditions and engine limitations. The Pilot Operating Handbook of the TBM 930 is freely available from Daher.

You can fly the aircraft to the numbers therein and get somewhat accurate results. As a sidenote, the autopilot in this simulator is very twitchy and imperfect at this time. So try using gentle inputs so it does not get out of hand.

2 Likes

I have been trying to test RNAV approaches at an add-on airfield I am working on and the only consistent way to make it work is to put an entire trip (airfield to airfield) into the Free Flight screen before starting the game (selecting ‘Low Altitude’ IFR so I can select the approaches). Anything I try to do in game is sketchy.

2 Likes

Did the devs say anything about it? It’s so hard to find real information because of the sheer volume of messages in the forums.

It’s so frustrating that the Garmin was released in this state, with lots of important features missing (I mean, we can’t even set a basic VNV profile) and what is actually implemented feels very janky. And then I read this: http://www.tbm.aero/daher-tbm-930-in-the-microsoft-fs2020/

"In creating Microsoft Flight Simulator 2020, the developers were assisted by engineers at Daher’s Aircraft Division to ensure the TBM 930 very fast turboprop aircraft’s characteristics are faithfully represented. Once finalized, the TBM 930 computer model underwent a final evaluation by the Daher engineering team."

I mean, really? :thinking:

4 Likes

You can also try to do it in flight, by entering a departure airport, and an arrival airport. Sometimes it works.
I actually stoped using rnav approach until the g1000 is fixed … tyred of losing so much time whith this.

Hello,

today I discovered similar situation for missing departure inside TBM in Poland Katowice airport. Departure list doesn’t show one that I need set, only for oposite runway heading. Nothing special, I click on rwy oposite and then all departures list appeared, I can select then also my required departure. Conclusion then can be that all is maybe included but due some bug in list items aren’t all departure/arrival/approach visible.

Just adding to this… The glidepath only reaches up to the intercept point and does not continue above it, as it should. This means that if you approach from any altitude above the intercept altitude, the glideslope indicator will be at the bottom of the gauge and you cannot intercept it.
Just to add to this one more time, the GS indicator appears as soon as you activate the approach, way before the IAF… which is also not correct.

3 Likes

Can reproduce, it’s completely broken. (latest patch as of 16/09/2020, 23:08 UTC)
Here’s a beautiful path of me trying to correct the issue and fighting against the AP which was failing to activate the leg to waypoint. (Kept redirecting me to origin)

Also, ATC does not ask me to lower my altitude, so there goes that too.
LXGB RNAV 27.
image

Tried to re-produce this issue once again. It also crashed the game at the end both times.
I tried to make a recording but OBS screwed up. I’m not going to be bothered to do QA for a company that has MS’ budget.
Here’s some extra info from the official discord:
image

KIOW is missing all approaches, though KCID got theirs back in the latest patch.

Thanks for this. I thought I was missing something since I could never get an RNAV approach to pick up the GS. The dot moves up and down but the APR AP never picks up (I’m in the TBM 930). I flew into Queensland (NZQN) and the waypoints work but even within a few NM the GS was never picked up.

ILS has always worked for me - except for the times it isn’t lined up with the runway :D.